OzoneLayer IE Support


I’ve recently been trying to get the OzoneLayer demo to work on IE, but have had no success so far. My environment is:
Internet Explorer 9 (9.0.8112.16421, 64-bit)
Jetty 8.1.7.v20120910
dontpush-demo-ozonelayer 0.3.3, with dependency on dontpush-addon-ozonelayer 1.0.2-SNAPSHOT

It works well with both FireFox and Chrome, but fails on IE with the following symptoms:

  • IE sends an XDomainRequest, which the server suspends
  • There is then a period of about ten seconds before IE sends a POST request with a connectionId of 0 (zero), which causes the connection to be terminated having printed "Failed to find resource for [0]
    " in the log / console.

IE9 does not support websockets communication, but I was under the impression - since Atmosphere is used under-the-hood - that OzoneLayer would automatically fall back to using long-polling under these circumstances. However, I am unable to get it to do so. Has anyone else managed to get the out-of-the-box demo running on IE9 (or 8 or 7…)? Or am I missing something and need to make changes somewhere? Any help gratefully received…



Last time I checked (during 1.0.0 release) it worked fine. However, few weeks ago I used a machine owned by our orienteering club with IE and it didn’t work. And I think it didn’t even work with FF. The reason was some old version of a firewall software that blocked odd looking http requests. If I remember correctly it was Comodo Internet security. I removed it and set up default MS firewall and MS Security Essentials → everything worked perfectly again. Could you check if you have similar issue? It would be great to know what kind of setups break the communication channel provided by Atmosphere.


Hi Matti,

Thanks for getting back so quickly with this.

We use Sophos Endpoint Security and Control v10.0 and, after a bit of experimenting, discovered that this is indeed the cause. In particular, I had to change Configure > Anti-Virus > Web Protection… > Download scanning to “Off” in order to get IE to work. This was the only setting I needed to change.

So now I have the demo working across FF, IE and Chrome and can move forward. Many thanks and good call!