No maven artifact by default with vaadin 7.4.3 & IntelliJ IDEA 14

[N.B. I am a total n00b to Vaadin, my apologies in advance if this is a stupid question, but I’m stuck and need help.]

With IntelliJ IDEA 14.1.1 (Ultimate) & Vaadin 7.4.3, creating an empty project from the maven archetype seems not to result in an artifact for the app, making it impossible to deploy (e.g. to tomcat) The maven used is the one bundled with IDEA, v3.0.5

This does not happen when I create a new app with just the vaadin plugin, without maven. In that case, I’m able to deploy the app to tomcat with no problems. But I need to use maven to manage dependencies and not depend on IntelliJ IDEA for builds, so I’m asking for your help.

Here are the steps to reproduce:

  1. In IntelliJ IDEA, create a new project
  2. Select “Maven” in the left column, check the “Create from archetype” box, and select the com.vaadin:vaadin-archetype-application:7.4.3
  3. Open the maven pane to the top right and run Lifecycle → package (this might take a while if you don’t have all the dependencies installed in the maven repo)
  4. From the “Run” menu, select “Edit Configurations…”, and click ‘+’ at the top left
  5. Select “Tomcat Server” → “Local” (this assumes you have already installed tomcat and enabled the IntelliJ plugin)
  6. Select the “Deployment” tab and click the ‘+’ button to the bottom left of the (empty) deployment list
  7. I should be seeing “Artifact…”, but all I see is “External Source…”

I see “Warning: No artifacts configured” at the bottom of the dialog.

Once again, apologies if I’ve missed something obvious, I’m new to a lot of this stuff.


Follow this steps I hope it will help:
Create new Maven Project from archetype with:
Select maven home directory
(Enable Auto Import from Maven Intellij should ask you this on top)
Press Edit Configuration, add a Maven, insert into command line “install”. and run Projekt if its done insert vaadin:compile into command line.
Now u can go on and configure your tomcat.
Add a new Tomcat go to deployment and add xxx:war and select where u wanna open it on the right.
Open your browser where u said it will be shown and there u have your Button;)
Hope that helps!
Sry for my english im done with work today :slight_smile:

Hi Tom,

Thanks! I found the problem, I had initially installed v1.0 of the Vaadin plugin for IntelliJ IDEA 13, and then upgraded to IDEA 14, but the plugin was still v1.0. Upgrading the plugin to the latest version (1.2.0) fixed the problem, the app artifact is now properly created.

Thanks for your help!