No components in Design View


I have a problem with the Eclipse Plugin (as many). On my Windows 7/64bit version, I get the error message that XULRunner cannot be started. I already found out that this is not a Vaadin issue although there are some thoughts to avoid it by integrating a WebKit.

Still I can open the design view and see nearly everything - except of the Components. The ‘Components’ header is there but no components inside.
Strangely enough, directly after installing the plugin, I got the design view WITH the components. Only after (unsuccessfully) trying to fix the XULRunner issue, they disappeared.

I tried a clean install of Eclipse (Juno) with the the Vaadin7 plugin on an old WinXP(32bit) machine with xulrunner but observe the same behaviour. Is this related to XULrunner?

If this can’t be fixed - what is the best practice to implement a complicated view. Drawing it by hand (with a drawing tool) and the copy the measurements to an absolute layout? Are there any recommended tools?

Many thanks

Since the mozilla people didnt fix this for the last 5 years or so, I guess they never will.

For design I do it on paper for my own orientation, or for presentation with tools like

Also, absolute layout makes much more work in the long run than letting vaadin do the pixel calculations automatical in realtime with vaadins percentage units, alignments and expand ratios etc.

Though the latter is somewhat more demanding for the programmer in the beginnig, it pays well in terms of scalability, customization and reusability, especially with complicated layouts when it comes to variable screen sizes.

The Visual Designer should work decently on Windows 7 even without XULRunner. You can safely ignore the popup saying that you should install XULRunner (just check the “do not show in the future” checkbox), the Visual Designer in that case will fallback to Internet Explorer.

However, if you are using IE10 you might run into some problems since the Visual Designer is written in (an old version of) Vaadin 6 which properly does not support IE10. I made an enhancement ticket about fixing that

Thanks Thomas. Makes sense. I’m just starting with visual development for a private project (my partner asked me for). So I don’t have much experience with UI approaches - yet.

Thanks John, as said, it worked - as I know now - in the beginning. But because I was worried about the error message, I tried to fix it and now all components are lost, i.e. I can’t drag&drop them on the design screen although I earlier created view still shows them. I attached a screenshot.
Any idea what causes this issue - or more important how can I get the components back?