New to Vaadin, new to Java

Hello there,

I have started programming about a year ago and worked solo at creating a C++ Windows Application. I have never programmed Java outside the occasional task at university for an exam or something - nothing serious.

Now my problem: I try to move this application to be web-based via Vaadin and thus Java. My problem is i don’t understand anything witht he help provided by the Vaadin tutorials, one example is the tutorial ( which expects you to know for each funcion you implement you also implement the corresponding “import”, so i.e. “private Binder binder = new Binder<>(Customer.class);” needs to be followed up by adding “import;” above, which is never mentioned nor described. Presumably its basic stuff, but as mentioned, i start from 0 and thus everything is new, so if something is not mentioned, it doesn’t exist to me - yet.

The problem starts there but can be contained, because i can look at the solution ( and learn backwards from that, but with every single step i try to take (example: i need to know something more about how to implement all those things (for example “cannot resolve method ‘setLabel(java.lang.String)’”), and i seem to be unable to learn it via google or the existing tutorials.

So long story short, i am totally new here, how should i get to the level that i can understand whats ment for beginners. Thanks in advance.


I haven’t actually watched this course: but I’ve heard good things about it. Maybe give it a try?

One problem is that i will need to rely on free / open content, this course seems to be pay to use, thus out of reach. Same goes for Vaadin Pro. Still thanks for the hint!

Have you tried something like or or ?

Thanks for the suggestions, I’ll dive straight into them, i hope they cover the errors i got so far.

I could fix some of the errors i got, but I want to post an example I’ve been working on for two days now:
I am trying to get this to work in my project. I added everything under “INSTALL WITH” and tried to follow this guide:

However when i insert this into my programm:
import com.vaadin.flow.component.charts.AbstractChartExample;
import com.vaadin.flow.component.charts.Chart;
import com.vaadin.flow.component.charts.model.AxisType;
import com.vaadin.flow.component.charts.model.ChartType;
import com.vaadin.flow.component.charts.model.Configuration;
import com.vaadin.flow.component.charts.model.Cursor;
import com.vaadin.flow.component.charts.model.DataLabels;
import com.vaadin.flow.component.charts.model.DataSeries;
import com.vaadin.flow.component.charts.model.DataSeriesItem;
import com.vaadin.flow.component.charts.model.PlotOptionsColumn;
import com.vaadin.flow.component.charts.model.XAxis;
import com.vaadin.flow.component.charts.model.YAxis;

Everyt last symbol is marked in red (here marked as bold).
I cant get this to work, thus i cant use any of the charts. Normally when i import something which isn’t used yet, its grayed out, so i assume there is something wrong already. However i cannot find any documentory about this, so maybe someone here can help me out.

Edit: Sorry for bad formatting, this editor shows way different format than the actual posts ends up with.

Did you run a Maven goal like install to fetch the dependencies?

I did now after I googled the term, and starting it as displayed in the screenshot. It didn’t change something, yet again, even if it would have worked, in what step was i supposed to learn or already know about it being an option or something i should know?

TL;DR: didn’t change anything, thanks either way

You might also click the refresh button; it’s in the top right corner of your screenshot there.

That actually fixed it, thank you!
everything but "import com.vaadin.flow.component.charts.AbstractChartExample;
" is now without red, i assume thats not within the actual code, but the example displayed on the page, so naturally it cant be loaded in - deleted and I think it works now :slight_smile:
Learned about two new buttons today, slowly getting there, thanks again.

Good to hear!