Migration to 5.1.0 - blank screen


I am a new Toolkit user. I’m working with a small application which at this point just fetches some user information from a database and shows it on the screen. The application uses version 4.0.2 of Toolkit and works fine.

Now I have a problem with migrating to the new version. I replaced the old jar with itmill-toolkit-5.1.0. jar and updated the deployment descriptor to com.itmill.toolkit.terminal.gwt.server.ApplicationServlet. When the application is deployed (on JBoss v4.0.2) and I try to open it with a browser, all I get is a blank screen. However the application itself seems to be working as the init() method runs normally, and all log messages are the same as with the old version. There are no error messages.

First I suspected it was a theme problem. The old version used “corporate” theme so I tried setTheme(“corporate”) and setTheme(null) and finally left setTheme out altogether. But it didn’t solve the problem.

What else should I try?


You could use Firebug to find out if for instance the theme is not found - just look for red rows in the “Net” tab :slight_smile:

However, I’m going to guess what’s wrong (because this step is not very obvious):
You’re probably serving the widgetset from the jar (as opposed to serving it from the WebContent/ITMILL -directory), and you don’t have an itmill toolkit app registered to the server root; in this case you need to make sure that you have a itmill toolkit application registered to the /ITMILL/* path, otherwise the resources can not be served from within the jar:


Did this help?

Best Regards,

My application is called WorkOrder. In web.xml, I have


Is this OK? It worked with the old version.

A strange thing is, it doesn’t seem to matter if I have gwt.server.ApplicationServlet or the old web.ApplicationServlet defining the servlet class when using version 5. Both give the same results (init method runs normally and blank screen is shown).

Try to add theme mapping as Marc suggested above.

I.e add:


I added this and it works. Thank you!

(I didn’t realize at first I needed to add the new mapping and not replace the existing one.)