Maven "Missing Artifact" for Addon

Hi there,

currently stuck on a seemingly easy project.
I made a test project in eclipse with vaadin 7 to work out if the ContextMenu Addon is good for my main project.
Unfortunately maven can’t seem to find the addon in the repository.

I’m quite new to maven and maybe I’m making a blatant error but I can’t find it on my own. Google gives me 100 answers, but I tried them all, nothing worked.

My pom.xml looks as follows:

<project xmlns="" xmlns:xsi=""




And the Error is:

Missing Artifact: 0rg.vaadin.addons:contextmenu:jar:4.2.1

I already tried some other addon but it yields me the same results.

Any ideas?

Your error message has a zero instead of an ‘o’ in org.vaadin.addons. Is that just a typo in the forum post or are you actually getting that?

Oh hi, er that’s just a typo. Error is still not solved. Any ideas on what it may hinge?

Are other add-ons such as vaadin-cdi loaded correctly? Have you tried some other version of the add-on (e.g. 4.2.0)?

Can you give a bit more context for the error? It can be normal e.g. for Maven to first try to load the add-on in one location, fail to find it there and then try the next repository, but that does not seem to be the case here.

Your POM is also missing at least widgetset compilation, but that would only come into play after the add-on is retrieved from Maven.