Liferay login problems

Hi everybody !

apart form forum subscription issues already mentioned here, I noticed another strange one - I’m unable to login to vaadin.com site (e.g. to liferay) - once I press “Login” link at the top of site, it just reloads and nothing happens. Only when I clear all vaadin.com cookies, “Login” link works and I’m able to authenticate. But this works only until my browser is open. Once I close it and reopen back - authentication is reset (yes, I pressed “remember me” at last login) and Im again anonymous. And when try to log in back - the same problem
comes back - click to “Login” link just refreshes the page.

Hi Dmitri,

We are running a scheduled update for vaadin.com later today. I’ll post again to this thread when the update is completed and then you could try and see if the problem still persists.

Regards,
Mikael

Now you could try again. Is this is still an issue?

With Chrome it works. With Firefox (Iceweasel) it is still no working.

I tried to login with Firefox (OSX, 5.0.1) with no problems.

There should be no configuration changes in the portal. Have you been able to login with Iceweasel before?

Is there anyone else who could test with Iceweasel?

Nope, still the same. Once you close all browser tabs and quits the browser, next time you’re not logged in and cannot login anymore as login link simply not working.

I suppose, the bug is specifically in “remember me” option. If I clear the cookies, then try to login but leave “remember me” box unchecked, next time I start the browser I’ll be logged out, but at least “login” link will be functional and bring me to login screen. So this (together with the browser password autofill) could be used as workaround to broken “remember me” option.

Dmitri

What OS/browser are you using?

Yes, login with Iceweasel worked before.

I don’t know if login works now for you, but i still have problems with logging in from:
OSX:

  • Firefox v5
  • Chrome v14

WinXP

  • IE7
  • IE8

The only browser which works (and with which i was able to post this) is safari…

Very strange :frowning:

Does anyone have an idea what i can do to my browsers (i’ve cleared already the caches and so on…) ??

Hi Martin,

could you describe in more detail what happens when you try to login (any error messages, etc)? I have succesfully used these browsers when logging in. Also are you by any chance accessing the site through a proxy?

Hi Teemu,

I try to open the login form with a click on “Sign In”, a request is send and the same page is loaded again (e.g. the forum).
My solution right now is using this URL to Login (I do not know why it works :smiley: ) which I had in my browser history:

https://vaadin.com/de/home?p_auth=2IPCZAsy&p_p_id=58&p_p_lifecycle=1&p_p_state=maximized&p_p_mode=view&saveLastPath=0&_58_struts_action=%2Flogin%2Flogin

I have tried logging in with and without a proxy, my browser is set to german and no error message is displayed…

I can see the same problem.
Windows XP Pro SP3, Firefox 7.
I left my work computer opened yesterday, and Firefox still running. This morning, I clicked on Edit Profile, knowing that if I was logged out, the action would be void.
I saw my history of posts, with a Sign In link in the black area. When I click on this link, I just get a page reload.
As usual here, I went to my cookies, deleted the multiple JSESSIONID and some other id cookies whose name I forgot and which I can’t seem to bring back…
Then I was able to log in again.
And, yes, there is a REMEMBER_ME cookie set to yes.

I get paranoid and copy my messages before hitting Publish, as I have lost a couple of them this way (dynamically generated text area means Firefox isn’t able to restore them when I do Back in the browser).