IvyIDE resolve problem

I have installed Eclipse Luna on a fresh copy of Ubuntu. I installed Vaadin from the Eclipse Marketplace and tried to create a test Vaadin 7 application. At this point after I enter the project name and click all the Next I get the following error:

An internal error occurred during: “IvyDE resolve”.
org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String

on a popup window of Eclipse.

After clicking OK on the error window the project is created but the vaadin references have not been resolved from IvyIDe.

Any suggestions?

Thank you

I temporary resolved the issue by updating the Apache Ivy Library with the last build provided from the update site:


How did you update it?

On Eclipse,

Help > Install New Software

I added a new repository using the link given above of the update site and then I installed/selected only the Appache IvyIDE Library.

Thank you! This helped.

I am hitting the same problem with IvyDE:
An internal error occurred during: “IvyDE resolve”.
org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String


, when I try to install IvyDE from its “last successful build” update site as Klaudeta suggested in this thread, there is an unresolvable conflict between IvyDE and Vaadin (details below).

I was attempting to follow the Book of Vaadin section “2.5. Creating and Running a Project with Eclipse” to create my first Vaadin application…

Your original request has been modified.
“Apache IvyDE” is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Apache IvyDE 2.3.0.beta1-201409280037-hudson-296 (org.apache.ivyde.feature.feature.group 2.3.0.beta1-201409280037-hudson-296)
Software currently installed: Vaadin Plug-in for Eclipse (com.vaadin.integration.eclipse.feature.group
Only one of the following can be installed at once:
Apache IvyDE 2.2.0.final-201311091524-RELEASE (org.apache.ivyde.eclipse 2.2.0.final-201311091524-RELEASE)
IvyDE Eclipse Plug-in (org.apache.ivyde.eclipse
IvyDE Eclipse Plug-in 2.0.0.final-200907011148-RELEASE (org.apache.ivyde.eclipse 2.0.0.final-200907011148-RELEASE)
Apache IvyDE 2.2.0.beta1-201203282058-RELEASE (org.apache.ivyde.eclipse 2.2.0.beta1-201203282058-RELEASE)
Apache IvyDE 2.3.0.beta1-201409280037-hudson-296 (org.apache.ivyde.eclipse 2.3.0.beta1-201409280037-hudson-296)
Cannot satisfy dependency:
From: Vaadin Plug-in for Eclipse (com.vaadin.integration.eclipse
To: bundle org.apache.ivyde.eclipse [2.2.0,2.3.0)
Cannot satisfy dependency:
From: Vaadin Plug-in for Eclipse (com.vaadin.integration.eclipse.feature.group
To: com.vaadin.integration.eclipse []

Cannot satisfy dependency:
From: Apache IvyDE 2.3.0.beta1-201409280037-hudson-296 (org.apache.ivyde.feature.feature.group 2.3.0.beta1-201409280037-hudson-296)
To: org.apache.ivyde.eclipse [2.3.0.beta1-201409280037-hudson-296]

Hi Jeffrey,

What I can understand from your post, it seems like you are trying to install also the Apache IvyIDE Eclipse plugins.

Try to install only the Apache Ivy library from the last successful build. At least this what it worked for me.

Hope it helps,

That did the trick. I had been trying to install “Apache IvyDE” under “Apache IvyDE Eclipse Plugins” from the last successful build. When I left Apache IvyDE alone and instead installed the two items under “Apache Ivy library”, I was subsequently able to create a Vaadin 7 project.


Thanks Klaudeta,

xou made my day. I already thought, some of my projects would be inaccessible until the next Luna update.


Thanks Klaudeta, a lot !

You are welcome

Thanks Klaudeta Mertiku. I also faced same kink of problem. Now it is ok.

Thanks Klaudeta it helped for me too!

Your solution works for me too. Thank you. :slight_smile:

Hi Klaudeta,
Still having an issue (was fine last week).
I installed the (Help->Install new software) ivy from:
It uninstalled vaadin plug-in for eclipse (conflict) and installed apache IvyDE and IvyDe resolve visualizer.
After restart:
I attempted to reinstall the vaadin plug (…) from eclipse marketplace and received the following error:

  • Will be uninstalled: apache ivyDE and IvyDE Resolve Visualizer
  • Will be installed: Vaadin plug-in for Eclipse (2.3.20140911338).
    ** canceled at this point

Any suggestions??

Hi Robert,

When you attempt to install the ivy from the link

you should check only Apache Ivy library and NOT Apache IvyIDE Eclipse plugins. At least this is how it worked fine for me with no conflicts and no need to uninstall vaadin plug-in for eclipse.

Hope it helps,


One more thing: you must do a standard install of Apache Ivy and IvyDE first, then do the installation of the updates, otherwise Eclipse can’t figure out the dependancies correctly.

Thanks Klaudeta for the workaround.

Hi Klaudeta,
I did install Apache Ivy library and not the IVyIDE eclipse plugin initially. It didn’t work the first couple of times.
I went back and forth (uninstalling and reinstalling in different orders and selecting an older versions of ivy) inaddition to installing only one plugin at a time. It finally worked and I then applied all of the updates which worked. I tried to document what I did but lost track. I also ran into a problem at the same time when trying to install Vaadin’s plugin through the marketplace. I received an error that the file was missing when it attempted to download. I installed Vaadin through the help → install new software. Part of the problem may of been issues with the Marketplace at the time of the reinstall and the other part was the compatibility issue with ivy. Thanks for the assistance.
It put me on track so I was able to get up and running.

There is a Eclipse patch for this now, its called “Eclipse 4.4.1 Patches for bug 445122”.

Use Help - Install New Software… and select “The Eclipse Project Updates” to find the patch.

Thanks a lot Bernd, this works and resolves the issue nicely.