Issues when trying to add ScreenDump -add-on

Hi everyone, my first post here. I’ve been having some problems trying to add this addon to my project:

I was initially getting just a little error message on the page where I tried to use this add-on, this is demonstrated in the attachment 1 and pasted here:

I had added a bunch of dependencies before, and just copy-pasted them to pom.xml -file and they worked like a charm, so I didn’t really know what to do here. I’m a somewhat experienced programmer, but a total greenhorn when it comes to Vaadin.

Then I followed some tutorials on the internet, added some rows to my web.xml, added a new widgetset.gwt.xml -file, got the widgetset to compile (I guess…) and now I’m getting the error message visible on attachment 2.

I’m using Vaadin 6.8.2 and JDK 1.7, my IDE is NetBeans, I’m using Maven and my version control is Subversion. The most bizarre part is, that my colleague who is developing this same application on Mac, but also with NetBeans, doesn’t have this problem, whereas I’m getting this on both my desktop and laptop. My OS is Win7 on both machines.

Rebooting the pc, clearing caches and restarting NetBeans and Glassfish didn’t help. I have no idea what to do next, nor does my colleague, so I’d appreciate any hints. Thanks in advance!

I’ll paste here the contents of my pom.xml and widgetset.gwt.xml -file.

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="" xmlns="" xmlns:web="" xsi:schemaLocation="" id="WebApp_ID" version="2.5">
    <display-name>Vaadin Web Application</display-name>
        <description>Vaadin production mode</description>
        <servlet-name>Vaadin Application Servlet</servlet-name>
            <description>Vaadin application class to start</description>
        <servlet-name>Vaadin Application Servlet</servlet-name>

<?xml version="1.0" encoding="UTF-8"?>
   "-//Google Inc.//DTD Google Web Toolkit 1.7.0//EN"
    <inherits name="org.vaadin.screendump.ScreendumpWidgetset" />

    <inherits name="com.vaadin.terminal.gwt.DefaultWidgetSet" />


EDIT: Ooops, wrong pom.xml pasted at first. Fixed that.

Just for information, if someone stumbles upon this post looking for the answer for this problem: apparently nobody knows one. Googling around brought up very little help.

I solved this by removing ScreenDumper which at the time of writing this is at experimental stage - maybe that was the problem all along. I still don’t know, but we were able to solve our problems with non-Vaadin libraries.