Issue with widgetset compilation of filteringtable addon

I am using eclipse with Ivy to work with addons. I downloaded filteringtable addon alongwith popupbutton addon which is a dependency. I did the following to compile the widgetset.

  1. Change in MyWidgetset
    I added this line

  2. Change in Ivy.xml
    I added these lines

            <dependency org="org.vaadin.addons" name="popupbutton" rev="2.4.1" />

I made sure both classpath and web-inf/lib folder has the required jars for filteringtable and popupbutton.
When I am running my application on tomcat server, I am getting this error message

Widgetset ‘’ does not contain implementation for org.tepi.filtertable.FilterTable. Check its component connector’s @Connect mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions.

I am not sure what is the issue. I have tried a bunch of things but nothing seems to work. Can someone please help?


first of all, since you’re using Ivy you don’t need to download the JARs and add them to WEB-INF/lib manually. Ivy will handle fetching the dependencies so you should remove the manually added JARs.

Are you sure you’re using the correct (compiled) widgetset? You can check this in either your servlet definition (typically in the UI class) or your web.xml, depending on which you are using.

Are there any errors during the widgetset compilation?



I have similar problem.

In an existing project with filteringtable-0.9.5.v7 and popupaddon-2.2.1, widget compilation is successful, but when I run the project I get the same message as OP.

If if change to filteringtable-0.9.11.v7 and popupbutton-2.4.1 it also compiles successfully, but when I run the project I get a NullPointerException on a TableInfo setConverter(FilterTable table) method. I am not sure this is related though.

Any ideas? Should I try with other versions of these addons? I got other vaadin addons as well, is it possible they need to be updated. (ContextMenu, dcharts, refresher, tableexport, confirmdialog)

I have to add to my previous comment, that I used vaadin 7.3.4 in ivy.xml when failure occurred. Recompiling with old 7.1.11 vaadin it works.

The problem with mine was the version. The addon works from 7.3 onwards and I was using an old version. You might also need to check your vaadin jars inside ivy cache.

I clean ivy cache from within eclipse before resolving, recompiling another vaadin version

I got a project with old (filteringtable-0.9.5, popupbutton-2.2.1) addons working with old vaadin (7.1.11).
I am trying to use newer vaadin. First I made a mistake and tried to use old addons with new vaadin.
So I got the message like you with old (filteringtable-0.9.5, popupbutton-2.2.1) with new vaadin (7.3.4).
With new addons (filteringtable-0.9.11.v7, popupbutton-2.4.1) with new vaadin (7.3.4) I get NullPointerException.