Issue with dontpush Ozone

Hi Guys,

Hoping someone here will have some clues. I need push functionality for some stuff I’m doing.

I downloaded the dontpush demo from:

Compiled it up, and deployed it. It worked. However, I recompiled it using a newer version of vaadin, deployed, and now it doesn’t work. I then tried downgrading back to the older version of vaadin. No dice. Very confused. No error messages in the console, just this message in the browser window:

“Connection to server appears to be broken. This may be due to a temporary network problem or the server has gone is offline or very busy. The connection may return automatically or you may try to reconnect/restart your app.”

I tried using a new version of apache, same thing. So my question does dontpush hold open some sockets? If so what sockets, and how do I get around this on redeploy?

If thats not it, then where else can I look?

I’m using java 1.6.0_21, tomcat 6.0.35, maven 2.2.1 to compile.

I’ve tried everything I can think of… help please…


I’ve faced this problem too.
Have you managed to solve this problem?


I just tried with latest Vaadin and ozonelayer add-on and it worked fine for me. I also committed pom with new versions. What exact versions didn’t work?