Is ICEPush not working with Vaadin 6.6 anymore?

I upgraded to Vaadin 6.6, did the widget compile via eclipse and everything else works fine except ICEPush.

ICEPush doesnt seem to get loaded in the browser [tried IE, FF, Opera, Chrome]
. I remember reading in some earlier post that one should see icepush.js being loaded in the browser. However I don’t see this javascript getting loaded.

My app is running under under Liferay 6.0.6 and I have the following set in web.xml:

        <servlet-name>ICEPush for Portlets</servlet-name>
        <servlet-name>ICEPush for Portlets</servlet-name>

I also tried to add the init param in my portlet in the portlet.xml:


but that didn’t do any good.

Btw I tried with both ICEPush 0.2.0 & 0.2.1 and neither seem to be working. Also, I dont see any errors when I call the icepush.push().

Vaadin is set in debug mode; should I be seeing any debug logs about the ICEPush servlet starting?

Any help/pointer [or at least confirmation that ICEPush doesn’t work with vaadin 6.6]
will be appreciated…

no one else having any issues or is ICEPush not being used that much?

Many people do, but I suspect not all that many people have switched to 6.6 just yet (I myself have not had time to test it – it uses a new version of GWT and this requires a little bit more care for those of us with complicated Maven setups).

I tested successfully the 0.1.2 version with Vaadin 6.6

Took me a fair bit of searching to update my Maven config, the instructions for the gwt-maven-plugin on the codehaus site are broken (the version they indicate does not actually exist). If using Maven with 6.6 and widgetset recompilation, see

I also wrote about this (more specifically in the Vaadin context)

I even remembered you writing about it, but could not find it when I needed it :frowning:

It would be very nice if the “Download” page referred to a current Maven POM, and a document that covered both “Getting Started” and “Updating” with Maven. My issue is that, like many users, I mostly use Maven to make my dependencies explicit, so I know just enough. So the POM sections you posted are indeed very much needed, and should be part of the release kit. And with the success of add-ons, the POM must include the widgetset magic – I remember that when I started using Vaadin I could not even answer the question as to which archetype I needed !

Also, rhetorical question, are the archetypes kept up to date with such changes ?

We release new Maven archetypes when we release new Vaadin versions. This helps people who are starting new projects but not as much people who are migrating from older versions. What needs to be done when updating from older versions in Maven projects is something we could document better e.g. in the release notes.

As a side note we are planning to renew the archetypes in the near future to make it clearer what you should use. Hopefully we will soon have two archetypes: application and addon instead of the current three with a bit weird names.

Sorry, but I am not following the conversation. I am just an end user of libraries, ie I merely include the libraries in my projects and hope for them to work. :grin: I havent done any maven/pom builds with any Vaadin project as of yet.

So are you guys suggesting that to make icepush component work with vaadin 6.6, I need to get the ice push component source code and build it locally?

The short answer is version 0.1.2 of IcePush does work with 6.6. I am not in a position to test the newer versions due to a design change in the add-on that clashes with one of my requirements.

Concerning the discussion, if you are developping with Eclipse with the plugin installed, you should indeed just add the jar, and the plugin should recompile the widgetset for you, and everything should work. Other people with complicated setups use Maven, and I was having trouble upgrading in order to perform the test you needed.

I did mention in my first post that I had compiled the widget set and everything else is working with 6.6. I thought there were substantial improvements in the latest icepush, that’s why I switched.

Based on your experience with 0.1.2; does it work well? I will try to switch back to it and see if it works… thanks for your replies…

I am on Vaadin-6.6.0 and Navigator7, with ICEPush currently removed for some reasons, which I can’t remember right now. It worked before I started using Navigator7. Anyway, will ICEPush work with Navigator7? If not, any workaround ?