Installing Vaadin plugin on Ubuntu machine

Hello everyone,

I tried vaadin before on my Windows machine, but now i want to try out little project with it. But problem is… i’m using Ubuntu on my working laptop and i have problems getting vaadin plugin installed on Eclipse. Everytime i try to install it - it starts from the place it broke and after a while gives same error over and over again:

Cannot complete the install because one or more required items could not be found.
  Software currently installed: Vaadin Plug-in for Eclipse (
  Missing requirement: Vaadin Plug-in for Eclipse (com.vaadin.integration.eclipse requires 'bundle org.eclipse.mylyn.commons.ui 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Vaadin Plug-in for Eclipse (
    To: com.vaadin.integration.eclipse []

I have a fought, that this happened then i tried to install plugin with very unstable wifi connection and some packages come corrupted. Now it always end up like this. How can I remove all the temporary file that it got already and try out installation from scratch? Any tip would be much appreciated

I think that the root cause is not a corrupted files but some missing dependencies, because I tried to install a plugin with 100% stable connection and got the same result. Details: Ubuntu 11.04, Eclipse 3.5.2.

The update system is not finding one of the Mylyn plugins that the Vaadin plugin depends on - either because your active update sites do not contain it or because some downloaded package or list is corrupted. By default, the update sites with the Mylyn plugins should be activated at least in the JEE package of Eclipse.

If you really have a corrupted Eclipse installation, cleaning it is not easy. If the update sites are ok, you could try to uninstall Vaadin and/or some Mylyn related plugins from Help → About Eclipse → Installation Details… (there at least in Helios) and then re-installing them, but there might be many dependencies on Mylyn.

Thanks Henri. Ubuntu installes eclipse with no mylyn(I guess it’s “IDE for Java Developers”).
So to make everything to work fine for Ubuntu and Eclipse and Tomcat installed from repo you need to perform the following steps:

  1. Install mylyn:
    Add “” to your update sites and install “Mylyn Features” from available software.

  2. Install tomcat server support(it might be not installed):
    Add “” to your update sites and install “JST Server Adapters”

  3. While adding tomcat server you may face the problem that ubuntu has a different tomcat folder structure, so you have to execute the following command from your terminal:
    cd /usr/share/tomcat6
    sudo ln -s /var/lib/tomcat6/conf conf
    sudo ln -s /etc/tomcat6/policy.d/03catalina.policy conf/catalina.policy
    sudo ln -s /var/log/tomcat6 log
    sudo chmod -R 777 /usr/share/tomcat6/conf
    sudo ln -s /var/lib/tomcat6/webapps webapps
    sudo chmod -R 777 /usr/share/tomcat6/webapps

After this you’ll be able to use tomcat from eclipse

After theese steps I was able to start a sample vaadin project

Great Oleg and Henri.

Mylyn package solved the problem :slight_smile: