IcePush + Don't Push Ozone Layer problem


Due to my app requirements I need server-side push. I have tried IcePush with Vaadin7, Don’t Push and Don’t Push Ozone with Vaadin 6.8.
Everything fails to start on Jetty and Tomcat. Under Eclipse and under simple Maven too.

Even this:
simply checked out, and run via:

mvn clean install jetty:run performs compilation, makes a WAR and then runs jetty… and fails.

INFO: Requested resource [VAADIN/widgetsets/org.vaadin.dontpush.demo.gwt.DontPus
hDemoWidgetset/org.vaadin.dontpush.demo.gwt.DontPushDemoWidgetset.nocache.js] no
t found from filesystem or through class loader. Add widgetset and/or theme JAR
to your classpath or add files to WebContent/VAADIN folder.

THIS and similar errors happen to deployments of all the mentioned push plugins via jetty:run and via Eclipse.
When I manually add plugin jars to Jetty runtime classpath in Eclipse (?!), then another error pops out:

that Jetty or Tomcat cannot find the servlet class. Weather it’s ICEPushServlet or DontPushServlet - it does not matter.

Deploying the compiled WAR via maven or manually of course works. But this is totally unusable from developers’ POV.

Am I doing something wrong? Probably everything, but why doesn’t it work out of the box? :frowning:

Maven 3, Jetty 8, Tomcat 7, Eclipse 3.5.

Kind regards,


P.S. Have already tried different gwt:compile, vaadin:compile-widgetset and eclipse compile-widgetset button options. They can only change the behavior from “Requested resource not found” to Servlet class not found.


I didn’t check this, but I’d guess the example project don’t use “in-place gwt compilation”.

Try with

mvn jetty:run-war


mvn jetty:run-exploded

For more details about “in-place compilation”, see gwt maven plugin home page.