Heroku deployment error

I downloaded the starter code and followed the heroku instruction from the vaadin documentation but when I deploy to heroku and open the application it says there is a application error yet when I run it locally it function normally. Anyone know what is causing this issue?

Did you create the app using the production profile before you deploy it?

Checkout my guide: Running a Vaadin Application on Heroku - Learn to Code with Simon Martinelli

I followed all of the steps in this tutorial and redeployed the jar file, and this is the error I got, it’s still the same.

What is in the logs?

2 main reasons why it happens:

  1. create system.properties file to project root folder, and fill java version line, Heroku will deploy your app and install this java version for your project to dyno cloud

  2. in application.properties addd server.port=${PORT:8080}

it means Heroku is using 8080 too, if your app use 8080 too, you have to add this property to recognize and not colission with app and heroku cloud

In most reasons I deployed to Heroku my apps those 2 problems were solved

you can see logs if you run in bash command heroku logs --tail, it will tell you more details where can be problem