GWT 2.0 dev mode not working properly

I’m having troubles getting the new devmode running correctly.

First of all, the launch file seemed to be wrong for me. Launching the file as it was produced a lot of “Java CocoaComponent compatibility mode” and “NSConditionLock unlock” errors on my OSX, which seemed to be linked to the “-XstartOnFirstThread” option in VM_ARGUMENTS, so I removed it. Now, the dev mode window launched correctly. This made me suspicious, however, since
states that OSX should require it. Did this already break stuff?

Anyways, the tale doesn’t end here.

Once I tried to access the devmode via browser with the “…?gwt.codesvr=…” -parameter, Firefox 3.6 was offered a plugin to install, which I did. But, after installing the plugin, and refreshing the page, FF just crashes immediately without warning. Each time the page is visited, FF crashes.

So, I tried with Safari instead. It, too, installed a plugin. But this time, when visiting the URI, everything starts to load a bit, and after a while, the DevMode window crashes instead, and Safari gives a nice notification that the DevMode didn’t respond, that I should relaunch and refresh the page. But the DevMode crashes all the time with Safari.

I’m using OS X Snow Leopard, Eclipse Helios/Ganymede, Vaadin Eclipse Integration, vaadin-6.3.0.nightly-20100216-c11348.jar and the plugin-provided GWT 2.0 gwt-dev.jar and gwt-user.jar.

What am I doing wrong, besides everything?

Have you uninstalled the old OOPHM plugin? They appear to conflict and cause FF to crash. It is also not mandatory to upgrade to the GWT 2.0 plugin and apparently the plugin download page will be displayed if there is no plugin or it cannot find the dev mode server. The old OOPHM plugin has at least worked for me with the new dev mode even though the dev mode console tells it is an old plugin that is connecting.

Just a guess but try to increase the memory for the dev mode process and see if it helps.

No, I hadn’t. Now that I uninstalled that, Firefox doesn’t crash anymore. Thanks!

Nope, didn’t help. I now have the same memory settings as I had with OOPHM, and it still crashes. Looking at the console output, the widgetset was loaded (it listed all the components to be loaded into the widgetset), and pretty soon after that it crashed. Eclipse’s console was left with a cryptic message, stating: “Invalid access of stack red zone 0x176c82ff8 rip=0x1010b0fd0”

After a quick Google, this seems to be some OSX JVM related memory error. The most cohesive answer I found on a quick schedule is
on Stack Overflow

Ah, the crashing was due to some weird infinite recursion in the magic widgetset I was trying to do. So that’s fixed now.