Getting started -> 7.7.7 The desired archetype does not exist :(

I tried to get started with version 7.7.7 by follwoing the getting started section:

mvn -B archetype:generate -DarchetypeGroupId=com.vaadin
-DarchetypeArtifactId=vaadin-archetype-application -DarchetypeVersion=7.7.7
-DgroupId=org.test -DartifactId=vaadin-app -Dversion=1.0-SNAPSHOT

Problem is that I get the following error:
The desired archetype does not exist (com.vaadin:vaadin-archetype-application:7.7.7)

I tested the same command with version 7.2.3 and it worked as expected.

Please try again with the -U switch. The archetype is in the archetype catalog of Maven Central (, and your command works for me, so I suspect your archetype catalog was cached somehow incorrectly.

Note that for pre-releases (such as Vaadin 8.0.0.rc1), you need to give an additional parameter or two to specify to use the pre-release repository by adding the parameter
-DarchetypeRepository= .

Thank you for your answer, I tried again with the following command:

mvn -B -U archetype:generate
-DarchetypeGroupId=com.vaadin -DarchetypeArtifactId=vaadin-archetype-application
-DarchetypeVersion=7.7.7 -DgroupId=org.test -DartifactId=vaadin-test -Dversion=1.0-SNAPSHOT

Still with the same result and one of my colleagues did the same and also got the same error message.

Could it be something else?

Henri, I can reproduce this. I tried executing mvn with the -X switch and I see

 Searching for remote catalog:

 Using catalog /Users/ollimurto/.m2/repository/archetype-catalog.xml

 Archetype repository not defined. Using the one from [com.vaadin:vaadin-archetype-application:7.7.7]
 found in catalog remote

 Not found archetype com.vaadin:vaadin-archetype-application:7.7.7 in cache

 Using transporter WagonTransporter with priority -1.0 for

 Using connector BasicRepositoryConnector with priority 0.0 for


 Writing tracking file /Users/ollimurto/.m2/repository/com/vaadin/vaadin-archetypes/7.7.7/vaadin-archetypes-7.7.7.pom.lastUpdated

 Archetype com.vaadin:vaadin-archetype-application:7.7.7 doesn't exist

org.apache.maven.archetype.downloader.DownloadException: Error downloading com.vaadin:vaadin-archetype-application:jar:7.7.7.
Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact com.vaadin:vaadin-archetypes:pom:7.7.7 in central (

in the stacktrace…

I think that should be “vaadin-archetype-application” instead of “vaadin-archetypes”, which is not found in the repository, correct?


Having this issue too, the problem is that vaadin-archetype-application defines vaadin-archetypes as parent pom, and that parent pom is the one missing @ maven central repo.

Any news when this could be fixed?

Thanks in advance.


version 7.7.4 onwards have the same problem. 7.7.3 works as it has


as parent and that artifact is found in maven central repo.

dunno what has changed between those versions, but at least 7.7.3 can get you started till the problem is fixed.

I can confirm this. Thanks for point this out, we’ve been blind. We are going to fix this immediately.

This was caused by maven-archetype-plugin version 3.0.0 update, which requires the parent to be deployed. We’ve fixed this now for versions 7.7.4-7.7.7 by deploying vaadin-archetypes to maven central.

Great! I can see them now at maven central

Thanks Pekka :wink: