GAE and Google map widget


Has anybody run the Google map widget with GAE? As most of us know, some classes in java aren’t yet supported in GAE that are used by the Google map widget (ex. Point2D.Double). I am a newbie and I don’t know how to make a workaround for this.

In general, what should be the most preferred way/method to workaround this type of issue? Should I make a dummy class for each unsupported class in GAE?

Please help.



I’ve tried making a dummy Point2D.Double class but it gave me a GAE error,

SEVERE: javax.servlet.ServletException: java.lang.NoClassDefFoundError: java.awt.geom.Point2D$Double is a restricted class. Please see the Google  App Engine developer's guide for more details.: javax.servlet.ServletException

I guess, GAE intentionally restricts these unsupported java classes. I’ve found an old post regarding the same issue here,

Henri Muurimaa wrote,

Does this mean that another way to solve this issue is to modify the GoogleMapWidget to use another similar custom class instead of java.awt.geom.Point2D.Double?

For the benefit of others experiencing similar problem, please refer to post

For some reason I do not know, the google map widget isn’t displaying anymore since yesterday. To be specific I think this only happens on a GAE based app. I thought I made some changes that may have caused my app not display the google map. But then, I’ve tried an old GAE-based app that I’ve deployed before in GAE and was always working (displaying the google map) until yesterday I’ve run it again and didn’t see the google map widget appear in the browser. To be very sure, I’ve downloaded the google map widget example and uploaded it in GAE, and same thing happened nothing was displayed.

However, this only happens on actual GAE but not on dev’t (local) GAE. Google had just updated GAE and it could have break or make our google map widget incompatible causing it not to display. Or it could be some GWT is updated.

my local dev’t GAE version: 1.5
latest GAE version: 1.5.3

Has anybody experienced this issue? I ran out of ideas already, and I’m sure my code didn’t break anything because as I’ve said even the old running GAE-based app with google map widget in it isn’t anymore displaying the google map widget. Please help…:wacko: