Flyway broken after upgrade Vaadin 24.4.1 and Spring Boot Starter 3.3.0

Hello,

This question is not really Vaadin related, but let me give a try here… I updated two sites to Vaadin 24.4.1 (from 24.3.12) and Spring Boot Starter 3.3.0 (from 3.2.5). Suddenly they can’t start anymore on the server and Flyway reports it’s not compatible with both PostgreSQL 13 and 15.

I see flyway by default is now 10.10.0, but even bumping it to latest 10.15.0 gives the same problem. In the earlier version of Spring Boot Starter, it was 9.22.3.

I guess a few of you here use the same combination, so maybe you have any idea what is happening? Or maybe I just need to revert that Flyway dependency to 9.22.3?

Thanks
Frank

Answering this question myself, in case someone has the same issue…

After asking the question here, I found this issue: Postgres 16.0 · Issue #3743 · flyway/flyway · GitHub

Since Flyway version 10+, PostgreSQL support has been moved into its own module.

My problem was that I only had this dependency:

        <dependency>
            <groupId>org.flywaydb</groupId>
            <artifactId>flyway-core</artifactId>
            <version>...</version>
        </dependency>

And I needed to add:

        <dependency>
            <groupId>org.flywaydb</groupId>
            <artifactId>flyway-database-postgresql</artifactId>
            <version>...</version>
        </dependency>
1 Like

Your issue is mentioned in the wiki / release note / migration of spring boot 3.3 as requirement

1 Like

As being a docs writer, I should know I need to read them before bumping versions, but still… ;-)

3 Likes

And I posted about that on Twitter after Spring Boot 3.3.0 came out :wink:

https://x.com/simas_ch/status/1793965273479082139?s=46

1 Like

What is Twitter? ;-)

3 Likes