favicon bug?


I’m very new to Vaadin and since I have not been using it long I am not sure if this is a bug or my error! :slight_smile:

I have created an application an deployed in on my server with a context of /myapp, so the application lives as;

This work great. However, the favicon is not right. When I look at the page source for the application it shows;

I think Vaadin is building this incorrectly, as it is missing the context. Should is not be without the leading / so that the resource is relative to the deployment of the webapp?

Additionally, I think Vaddin should also (by default) add a non-IE favicon meta too, such as;

So the app can have a decent alpha transparent icon instead of the crap IE ico format! :slight_smile:


Could you
create tickets
about these. If the context is truly missing and the link broken, I would consider the first one a bug, whereas the second would be an enhancement request.

I am having the same issue, but the original post is rather old. I could not find a bug report in Trac (closed or open).

I’m using Vaadin 6.6.2 on TomCat 7. I’ve tried FF 3.6 and IE 8.

Page source:

I can see the icon from this URL:

My app is running at this local URL:

My web.xml has:

My Application

My Application

Problem ‘solved’ by clearing the browser cache (and restarting FF).