Failed to load the widgetset


I am trying to deploy my webapplication to a cloud service running tomcat 5.5 on debian linux. So far i have managed to install and almost configure the application using the WAR deployment on tomcat manager. I just dont know how to configure toolkit since i receive following error:

Failed to load the widgetset: /WebApp/ITMILL/widgetsets/com.itmill.toolkit.terminal.gwt.DefaultWidgetSet/com.itmill.toolkit.terminal.gwt.DefaultWidgetSet.nocache.js

before this message appears i can see the main application window scrollbars.

i have tomcat 5.5 configuration on my development environment and using the same deployment method works. I am using RC 12 jar-file (in web-inf/ lib folder) and i have tried with and without widgetset directory (to use widgetsets in jar) and using the /ITMILL/* servlet-mapping as someone suggest in the forum but without any results. I also tried using security permissions also described here. So i am running out of tricks :slight_smile:

what am i missing?

What does server reply if you enter that widgetset-file to browsers url?
404 error perhaps?

Try WITH widgets directory, it feels more robust way, and make sure they exists in tomcat-home/webapps/WebApp/ITMILL.

If you still have problems try to add tomcats directory-listing servlet:


Thanks for the advice!

i tried both ways but unfortunately with the opposite results:)

With widgetset directory and Without directory-listing servlet the browser returned javascript content ,so it is accessible. when i tried WITH widgetset directory and directory-listing servlet i got 404 :slight_smile:

one difference between these environments are that in development environment the webapp runs on tomcat alone, but in cloud service it runs with apache. so in clound service the application url is http://server/TOMCAT/WebApp while in development its just plain http://server/WebApp.

that might be the cause since the reference to js file (/WebApp/ITMILL/widgetsets/…) is neither root path as in http://server/WebApp/ITMILL… or its not relative http://server/TOMCAT/WebApp/WebApp/ITMILL ← notice the double “WebApp” is on purpose.

Could this one be solved by configuring the location where toolkits looks for the js? if so, how can this be done?

I have this trouble to. After I changed




everything worked

Second way to fix my trouble: remove block


from my web.xml

Hello, I am facing a similar problem, though it’s not quite the same. I’m trying to install my application on a sever running with Ubuntu Server, on Tomcat 6.0, but i get the following error:

Failed to load the widgetset: /SPA v1.0/VAADIN/widgetsets/com.vaadin.terminal.gwt.DefaultWidgetSet/com.vaadin.terminal.gwt.DefaultWidgetSet.nocache.js?1291629217325

Apart of his problem, I can’t see any of my application running, since I assume the problem is with the Vaadin section of the project. Is it the same error? The solutions are the same or different?

Thank you for your attention, and i apologize for my lack of knowledge, since I’m starting on the language.

My first guess is that a space character in the URL might be causing problems (“/SPA v1.0/”).
Not sure if this is the only issue, but try to change that first.

Had the same problem for a few minutes. One of the previous posters had the right idea, they were using the old product name. Here is what I did to correct the issue:

In web.xml:


Notice the url pattern is pointing to the new(er) name for the widget location.


… of course this action likely means I have something else not set correctly, however for now it works nicely.

I am anovice with Vaadin and I would like using some add-on in my project.
Therefore, I included the dependencies in my pom (I have a maven project) but, after running with Wildfly, a error message suddenly appeared (Failed to load the widgetset: ./VAADIN/widgetsets/
May you help me? I tried with other solutions using many components but I found the same problem with all add-on. Enclosed hereby please find my code source.
Thanks to everybody. (587 Bytes)
20802.xml (1.63 KB)
20803.xml (7.43 KB)
20804.xml (355 Bytes)

Dear, to problems of this type:
Please try the following.
0. Uncomment the dependencies in the POM archive, see image.

  1. In your IDE find the option: run compile widgetset
  2. Re-run your project.
    In my case it solved the problem, in theory this should be done every time a new project is created in vaadin.

Here, attached for step 0.

i am facing the same problem where the Widgetset fails to load.
i even sometimes have the bootstrap loading failure.

by the attached picture, it can be seen that its probabbly not configuration errors (i assume the vaadin team is responsible for the vaadin website).

is there any way of not showing such an error on the client side?
are you approaching this error?
will there be a fix to that issue?