Failed to load custom widgetset (Vaadin + Spring)

Hello guys,

I’ve already spent more than a day on this, so I finally gave up and decided to call for help.

We’re developing a prototype which was working fine until we decided to add the EasyUpload add-on. Now, we have a custom widgetset which is built just fine, but at runtime it fails to load.

Here’s the relevant dispatcher servlet snippet:

<bean id="applicationServlet" class="org.springframework.web.servlet.mvc.ServletWrappingController"
    p:servletClass="com.ontotext.vaadin.utils.AutowiringApplicationServlet" depends-on="config">
    <property name="initParameters">
        <prop key="application">com.ontotext.vaadin.GateExplorerApplication</prop>
        <prop key="productionMode">${vaadin.productionMode}</prop>
        <prop key="widgetset">com.ontotext.vaadin.mant.widgetset.MantWidgetset</prop>

  <bean id="urlMappings" class="org.springframework.web.servlet.handler.SimpleUrlHandlerMapping">
    <property name="urlMap">
        <entry key="/*" value-ref="applicationServlet" />

And here’s the web.xml configuration:


And the widgetset is very simple, it just:

  <inherits name="com.vaadin.terminal.gwt.DefaultWidgetSet" />
  <inherits name="org.vaadin.easyuploads.EasyuploadsWidgetset" />

So, this doesn’t work and fails with [quote]
Failed to load the widgetset: /gate-document-explorer/VAADIN/widgetsets/com.ontotext.vaadin.mant.widgetset.MantWidgetset/com.ontotext.vaadin.mant.widgetset.MantWidgetset.nocache.js?1344249503781

I’ve also tried to map the vaadin servlet to /appName/* and /VAADIN/* with no success (same error).

Can you see something wrong? Any help is much appreciated!


Turns out the issue occurs only when we’re using the maven-jetty-plugin to start the web application. When deployed to a Tomcat instance it works just fine.