Failed to load application class

I am trying to run the form code given in vaadin sampler but it is giving me following error.
Anyone knows how to resolve it.

javax.servlet.ServletException: Failed to load application class: com.example.vaadin.MyApplication

Double check that the application deployment succeeded and the MyApplication class is really in the right place in your servlet container.

thanks but still i am getting same error
you can check that i am giving my web.xml file

<?xml version="1.0" encoding="UTF-8"?> VaadinApplication com.vaadin.terminal.gwt.server.ApplicationServlet application com.example.vaadin.MyApplication VaadinApplication /vaadin/* VaadinApplication /VAADIN/* 30

Your web.xml seems little bit odd. I would change it something like this

<?xml version="1.0" encoding="UTF-8"?>
<web-app version="3.0" xmlns=""

Check also that your project is fully compiled and there is not compilation errors.

I have followed the steps mentioned in the
But still I am getting same exception.

SEVERE: Allocate exception for servlet Vaadinproject1
javax.servlet.ServletException: Failed to load application class: com.infor.vaadinproject1.Vaadinproject1Application
at com.vaadin.terminal.gwt.server.ApplicationServlet.init(
at org.apache.catalina.core.StandardWrapper.initServlet(
at org.apache.catalina.core.StandardWrapper.loadServlet(
at org.apache.catalina.core.StandardWrapper.allocate(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.valves.AccessLogValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.AbstractHttp11Processor.process(
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
at java.util.concurrent.ThreadPoolExecutor$

This is not a Vaadin specific problem but something wrong elsewhere in your environment, project structure or deployment - Google for “SEVERE: Allocate exception for servlet” (with the quotes). Could be an issue with capitalization of class names, invalid class path or something else.

I got the exception when I was using STS and Eclipse Indigo.
The application ran successfully when i used Eclipse ganymede. It worked just like that. I just followed the steps in

I didn’t understand why it didn’t work with STS. Actually we need to use STS as our IDE.
Can you please help me how i can make it as workable with STS.
Actually we need to use combination of Spring and vaadin.


I have used STS with Vaadin (and Spring in conjunction with Spring Roo) without problems.

The problem may be some small issue in your project structure (have you tried re-doing it from scratch?) or e.g. in the configuration of the server on which you are trying to run the servlet. Your exception is not quite the same as in the beginning of this thread and seems to point to some other problem but does not give much more specific information about it.