Fail to load widgetset

There are already have lots of same topics, I check but cannot fix.
I try to clean install in 2 different env and hit same problem

  1. all use jdk1.8.0_45 +
    eclipse-jee-mars-R-win32-x86_64 + apache-tomcat-8.0.24/eclipse-jee-luna-SR2-win32-x86_64+apache-tomcat-7.0.63
  2. then go to eclipse market, install Apache IvyDE, then restart. Vaadin Plugin for Eclipse then restart.
  3. go to server perspective, install new tomcat server.
  4. creat new Vaadin 7 Project, input project name TestUI. press finish wait ivy finish.
  5. add new Vaadin Widget just click finish.
  6. check the TestuiWidgetset.gwt.xml generate and the already generate these information
    @WebServlet(value = “/*”, asyncSupported = true)
    @VaadinServletConfiguration(productionMode = false, ui = TestuiUI.class, widgetset = “com.example.testui.TestuiWidgetset”)
  7. right click project and run on server
  8. always hit same error.
    INFO: Requested resource
    [/VAADIN/widgetsets/com.example.testui.TestuiWidgetset/com.example.testui.TestuiWidgetset.nocache.js] not found from filesystem or through class loader. Add widgetset and/or theme JAR to your classpath or add files to WebContent/VAADIN folder.

How to fix,
Note 1. I try to define web.xml and remove annotation, it hit same error.
Note 2. remove widgetset = “com.example.testui.TestuiWidgetset”, the sample click button works fine (with annotation or with web.xml).
Note 3. I don’t want to use maven.


Note 4. test in 2 env, because eclipse-jee-mars-R-win32-x86_64 + apache-tomcat-8.0.24 use servlet API 3.1,
eclipse-jee-luna-SR2-win32-x86_64+apache-tomcat-7.0.63 use servlet API 3.0

Either you forgot to mention it or you forgot to compile your widgetset. In your eclipse there be a button with two cogs as its icon. Click the down arrow next to it and choose Compile Widgetset (or widgetset and Theme) while you have your gwt.xml or the project selected in the project explorer. Wait for the compilation to finish and then start/restart your server.

thanks, it works.
I don’t know the compile button before (not mention in Book of Vaadin or other relate post).

Previous I use GWT, I can compile just right click and it have option Google/GWT Compile option, but not saw in Vaadin plugin, so I post this question.
thanks again.