Error "java.lang.NullPointerException " at test run for GAE + Vaadin


First of all, I am very amazed to know there are such people ( vaadin devs) who are making our lives easier, especially to the Java Desktop Devs like me. Or a complete J2EE newbie. Vaadin is the best web developer solution I’ve known so far.

Now to my problem. I had followed the tuts on setting up my project and deploying my Vaadin+GAE app and so far made it successfully. But when I’ve tried running it on my dev setup, I always get the ff. error.

HTTP Status 500 -

type Exception report


description The server encountered an internal error () that prevented it from fulfilling this request.



note The full stack trace of the root cause is available in the Apache Tomcat/6.0.26 logs.

Apache Tomcat/6.0.26

I’m a complete newbie and I’m more inclined on that I’ve done something wrong here. I have also encountered issue described in

and followed the solution - remove “web libraries” and manually add the non-GAE libs. So far, I think I’ve followed this correctly.

Can somebody help me on this? I also notice the error I’m getting is not anywhere publish or raised yet. :wacko:

Still getting this problem, and I didn’t find any useful information while googling. All I learned is that the “namespace” here is an object but in this case it’s null. null return values are said to be legal (

This may be a serialization issue. But I’m just guessing, the reason is that I saw a lot of issues while googling related to serialization of objects in GAE.

If there’s somebody who have tried using Vaadin + GAE, please tell me how you set it up with Eclipse and Vaadin plugin. You might have encountered some specific config that is not mentioned in the Vaadin + GAE Development setup tutorial that could help me. Thank you. :frowning:

Do I understand you correctly that you try to run a GAE application on a local Tomcat? If this is the case it won’t work as GAE / GAEApplicationServlet uses services only available in GAE, for instance memcache. Sure, you might get it to work if you install all services manually in your Tomcat but the preferred way is to use the local development server included in Google’s App Engine Eclipse plugin. This uses an environment similar to GAE and works out of the box with Vaadin.

Vaadin wiki contains instructions on how to start development with GAE: although I do not think it talks very much about the development server.


Try to run (debug) with “Web Application” using eclipse plugin.
(Vaadin 6.4.5 GAE1.3.7 Eclipse 3.6)