Eclipse+Vaadin Plugin + Linux fails to open composite

Here is what happens. I downloaded a fresh copy of Eclipse and installed it (this is to ensure no problems are caused by all the random plugins I have installed in my main system). This is the Eclipse+Java package so it just has the eclipse IDE and Mylyn. I removed Mylyn.

I installed the Vaadin plugin and created a Vaadin project in my empty workspace. All good.

Then I created a Vaadin Composite and that worked in that it created a Java file that looks like this:

When I try to open it though I get a long stack trace in the eclipse log (below). It looks like it is trying to do something with mozilla and not finding a library. I checked the locations it is looking for and and they are there on my disk. Anyone know what is going on?

vaadin 6.6.4
Vaadin Bundle For Eclipse
Vaadin Plug-in for Eclipse
Eclipse Helios Service Release 2 Build id: 20110218-0911
FireFox 5.0
Ubuntu 11.04
Java java-6-sun-

here’s the stack trace:

Just to check, do you have XULRunner installed? If not, something like
sudo apt-get install xulrunner-2.0
should do the trick.

I didn’t but I do now and it did not make any difference.
Thanks for the reply, though, I’m sure it is a step along the way.
Actually I think the problem is affecting things other than the Vaadin plugin.
If the internal browser is invoked then this error shows.
So there’s some underlying problem (which made your suggestion look very hopeful)

I downloaded and installed this package (couldn’t see how to do it except manually):

and then it worked.

I still have xulrunner installed too, so that might be part of the solution.
There are old references to issues in Eclipse:

For reference.

This issue came up on my Fedora 15 machine as well, here are the steps I had to do to get it to work:

  1. SWT does not come preinstalled anymore. You need to install it by issuing
    yum install eclipse-swt
  2. Eclipse might still complain that about a missing MOZILLA_FIVE_HOME path. You can resolve this issue by adding
    export MOZILLA_FIVE_HOME=“/usr/lib64/xulrunner-2”
    to your .bash_profile. Change path accordingly if you are not using a 64bit system. Remember to log out and in again after the change!
  3. If that did not work, ensure that you have XULRunner installed and the path to it is set correctly.