Eclipse Plugin problem

I have just installed Fedora 16 on my development machine. I did a ‘yum install eclipse’ and it installed version ‘Indigo’. When I try to install the Vaadin plugin, I get this:

Cannot complete the install because one or more required items could not be found.
Software being installed: Vaadin Eclipse Integration (
Missing requirement: Vaadin Eclipse Integration ( requires ‘org.eclipse.jst.j2ee.web 0.0.0’ but it could not be found

I need to get up and running ASAP - I’m not an Eclipse wizard - can someone tell me what I need to do to make this work??



Eclipse comes in different versions
see list on eclipse website

I don’t know which version is packaged in fedora as “eclipse” but it may be “eclipse for java developers”.
For web development you would need “eclipse for java EE developers”, it is possible to migrate from java to java EE but it is quite tricky.

I would recommand you to remove the “eclipse” package and install the jave EE version.
If you can’t find a pre packaged version for fedora, you can install it directly from the
eclipse website


I know this is a late response, but I stumbled upon your post when I ran into the same error!
This came up in a Google search, so I figured it may help someone else.
Note: I did however run into this error using a different IDE (Eclipse Juno, 64-bit).

I was able to install the WTP extension
installing the JDT extension.

I hope that helps.