Eclipse Plugin Installation fails

Hi there,

I am new to vaadin and have some problems when installing the eclipse plugin.

Installation chrashes, showing the Message: "
Cannot complete the install because one or more required items could not be found.
Software currently installed: Vaadin Plug-in for Eclipse (
Missing requirement: Vaadin Plug-in for Eclipse (com.vaadin.integration.eclipse requires ‘bundle org.eclipse.mylyn.commons.ui 0.0.0’ but it could not be found
Cannot satisfy dependency:
From: Vaadin Plug-in for Eclipse (
To: com.vaadin.integration.eclipse []

What is this
‘bundle org.eclipse.mylyn.commons.ui 0.0.0’
good for, and where can I get it?
I am running Eclipse Platform 3.7.2 in Ubuntu 12.04 and tryed “” to install it.

Does anyone know how to solve this problem?

Thanks in advance,


I have same problem today. I tried to install last plugin to Eclipse Juno and also to Indigo from But it doesn’t work. I have same error message.

Does anybody know how to install this last plugin to the Eclipse?

The images in your post are not accessible, but what I believe you are seeing:

The latest experimental version of the plug-in now depends on IvyDE, which has a separate update site. You can either first install it from Eclipse Marketplace or from its update site, or add that update site in the default set and let Eclipse search it when installing the Vaadin plug-in.

As far as I know, the old update site format currently used for the Vaadin plug-in does not support specifying update sites for dependencies. The new update site format should support those, but that requires upgrading how we build the plug-in and its update site (in a way that is still also compatible with older Eclipse versions), which is not yet done.