Eclipse not finding Vaadin..

I have built a new development system using Fedora 20. I installed Eclipse (Luna). I have added the Bugzilla patch (445122) for Luna and the Vaadin plugin. When I select a new project, Vaadin is not one of the options. Has something changed, or is there something else I need to do to create a Vaadin project now? I have used Eclipse-Kepler in the past - this is my first try at Luna…



I installed the plugin under my own userid, and eclipse does not seem to find it. I went back, ran eclipse as root and installed the patch and plugin under the root id. I had to chown all the eclipse files to my userid after that, but now when I log in as myself, the Vaadin plugin appears to be available. Problen worked around… Eclipse has some quirks - you can only install and update it as root apparently, unless I’m missing something…

You can install Eclipse completely under your own user account (just unzip the distribution somewhere) or as root or some other user using the package manager of your Linux distribution, but the latter can have some restrictions with permissions. Such common installations used to be unusable some ten years ago, the situation is now much better but still not perfect with plug-in management.

Control and the possiblity to use multiple Eclipse versions in parallel have driven me to have my Eclipse installations under my own account.