Eclipse 3.6: No Vaadin library available

I have installed Vaadin Eclipse Plugin, but when creating a project, there is no Vaadin library available in the dropdown list. After clicking ‘Download’ button in the Project Property page, also no libraries displayed.

Anything I missed out ?

If there is only one library needed (vaddin-6.4.5.jar), I can just copy over to my project right?



The dropdown is initially empty but the list provided when clicking download is fetched from and should not be empty. My guess would be a problem with Eclipse connecting to the Vaadin server. Are you using Eclipse Helios and a proxy server? There seems to be some problem with Vaadin not using the proxy server in the newest Eclipse (

The vaadin-6.4.5.jar is all you need and you can add it manually to your project if you can’t get the Eclipse plugin to do it automatically for you.

Same problem here with Galileo and http proxy.

Don’t know which steps are unnecessary, but it worked after the following:

  1. Try the “Download” Button (and get an empty list)
  2. Go to Window > Preferences > Install/Update > Available Software Sites and do a connection test with vaadin
  3. Try again, now it should work.

Maybe it’s just enough to close the wizard once and try again, or maybe point 2. does something important.

It is proxy problem. It is ok if I work in a no proxy network.

How you have your proxy configured? Just tested last week with and without proxy (both native and manual in Eclipse) and everything worked without problems.

Sorry, no idea.

I’ll try if it works again after rebooting and so on, tomorrow.