DontPushOzaoneLayer with forms authentication

I’ve posted the following issue on the DontPushOzoneLayer add-on issues page, but having looked at the issues raised, it doesn’t seem to be a terribly high traffic area, so I’m cross-posting to the forums in case anyone else can provide a solution.

The basic issue is that I can’t get forms based authentication to work when using DontPushOzoneLayer - the requirement for forms based authentication to ‘move’ the app from /* to /ui/* seems to break it. Anyway, from the issue report…

[font=Courier New]

What steps will reproduce the problem?

  1. Build Vaadin App secured using forms based authentication (as per forms bit of
  2. App will now be mapped at /ui/* rather than /*, with index.jsp doing a redirection
  3. Observe correct functioning of login form, and redirection to the app
  4. Convert to using DontPushOzoneLayer by adding Atmosphere servlet, mapped to /UIDL/*

The behaviour is that the login proceeds, the basic Vaadin ‘boot’ page loads, but it cannot pull the actual content of the app (via UIDL I assume). I’ve tried mapping to /ui/UIDL too (in both web.xml and atmosphere.xml), with the same result.

If one has the app at /* rather /ui/*, (i.e. without the authentication), it all works perfectly.

What is the expected output? What do you see instead?

After 10 seconds with the ‘thinking wheel’, the app disconnects, giving the red message with reconnect/restart etc. Clicking any of the buttons causes the page to refresh, but the same end result.

What version of the product are you using? On what operating system?

Using version Vaadin 6.8.9, DontPush 1.0.4, and Atmosphere 1.0.13 (tried 1.0.9 too) WebSockets disabled due to issues with tomcat/firefox.

Tomcat 7.0.41, Windows 7.

Please provide any additional information below.

Hope you can give me an idea of how to map the Atmosphere servlet so it works!

[/font][font=Courier New]

[/font][font=Courier New]