DontPush -- was working, now broken

Note: I originally posted this in the wrong forum group, and couldn’t figure out how to “move” it, so I am reporting it here in the add on group.

Not along ago I added DontPush support to my test app. It worked fine. Recently it stopped working. After the yellow spinner spins for a few seconds I always get “Ooops…
Connection to server appears to be broken…”. I have tried recompiling, reinstalling, rebooting, and reverting my code but nothing works. Don’t know what else to try or what could possibly have changed. Any suggestions?

BTW: I see here that someone else had a similar experience – worked, then stopped working. I’m still waiting for mine to spontaneously start working. Maybe I have to let it rest a month :wink:


Here’s an update…

Today I tried it again (with Firefox), and it again kept failing.

On a whim I tried it with Chrome, and it worked – once. After restarting Chrome, it fails in Cjhrome. Restarting the server (Tomcat and/or Eclipse builtin) it still fails.

Then I tried IE – it works. In IE it works even if I restart the browser or restart either server.

Back to firefox. I restarted Firefox, and it worked. I restarted Firefox, and it didn’t work. I restarted Firefox and it works. I restarted Firefox, and it works.

IE still works. Chrome now never works. Firefox sometimes works.

Pretty weird. Any idea what might be the problem?

It seems that the presence of the final “/” in the URL has a significant effect. Leaving it off generally allows the app to start successfully. Since this is awfully subtle, perhaps this explains the seemingly inexplicable behavior I described above: Sometime the “/” was include – failure – and sometimes it was not included – success. Note that back buttons and autocompletion and event the restart/reconnect buttons all handle the final “/” differently.

Perhaps others can confirm and a fix can be released in dontpush.