Dispair of error "Failed to load the bootstrap javascript: ./VAADIN/vaadinB

On my local system my application runs fine. But deploying this application to my webhosters Tomcat it doesn’t run there. I tried everthing found in dozens of posts but nothing solved this problem.

I use Vaadin 7.3.6, Tomcat 7, Servlet API 3.0.

my guess is, that someting in my web.xml is wrong. I have attached it to this post.

Thank you for help,
17438.xml (1.57 KB)

Do you use push and websockets? Maybe yours webhosters blocking push requests?

I removed the push-mode and async-support from my web.xml, but unfortunately it hasn’t an impact

Can you paste some entries from log where exception occurred at server side?

Do you have in war own compiled wigetsets or lib/vaadin-client-compiled.jar ?

I guess, there is no exception at server side, when I start the application - neither in catalina.out nor in catalina.log. Or is there another log-file? The last vaadin startup protocol from catalina.out I have attached.

I have no own compiled widgetset but the file vaadin-client-compiled-7.3 in WEB-INF/lib folder.
17439.txt (6.26 KB)

Can you check if you have access to: http://your_address/VAADIN/vaadinBootstrap.js ?

If you don’t see anything, problem is related to your hosting. They block access to /VAADIN/ directory.

try add this in you web.xml file :


I tried this already - without success.

the URL http://www.qufis.de/YourFinex/vaadinBoostrap.js causes a 404 response.
I understood, that vaadinBoostrap.js is part of vaadin-server.jar. This file is located in WEB-INF/lib. I don’t understand why it should be reached with this URL?

Correct url: http://www.qufis.de/YourFinex/VAADIN/vaadinBoostrap.js displays 404.

It’s look like your provdier blocks access to VAADIN directory. I don’t know why, but without access to this directory, Vaadin cannot load all static data required to run (widgetset/theme/images). You can try move all static data to CDN like it’s explained in following article:

Can you please explain, why the URL should work, when vaadinBoostrap.js isn’t located in YourFinex/VAADIN but in YourFinex/WEB-INF/lib/vaadin-server.jar?

The permissions to VAADIN directory is as WEB-INF or META-INF set to 755.

I copied vaadinBoostrap.js to VAADIN directory - without effect. It’s very annoying to spend such much time with this problem.


It’s working, because the webserver treats all jars from WEB-INF/lib as classpath files for your application. If you don’t have vaadinBootstrap.js in WEB-INF/VAADIN, tomcat load that file from vaadin-server.jar which contains it.

Can you try to deploy my test project (
) into your provider and see if it’s works?

Hi Lukasz,
actually it was a wrong configuration in the providers environment.

Thanks a lot for your help!