Disabling Button makes it fully invisible

I am desesperately trying to disable a button, but I can’t, since the button disappears completely, thus the behaviour of button.setEnable(false) is in reality exactly the same as button.setVisible(false)… Same trivial code as in attachment produce different result, not as in the book. Instead I have just the Enabled button, the second button Disabled which should be disabled, is just invisible.

I am using Vaadin 7.5.2. Is it normal for button.setEnabled(false); to behave like that?

P.S.: I first tried it with Valo, then with Reindeer - no difference, so probably it is not about theme.
20929.png

Hi,

Just did a quick example using the code in the image using a 7.5.2 maven project and it worked as expected

[code]
@Override
protected void init(VaadinRequest vaadinRequest) {
final HorizontalLayout layout = new HorizontalLayout();
layout.setMargin(true);
setContent(layout);

    Button enabledButton = new Button("enabled");
    enabledButton.setEnabled(true);
    Button disabledButton = new Button("disabled");
    disabledButton.setEnabled(false);

    layout.addComponent(enabledButton);
    layout.addComponent(disabledButton);
}

[/code]Are you working in a clean new project? Anything in special?

20930.png

Right, the button greys out like it should, on my PC at home. But it’s not at work. Clean new Vaadin 7 project (no Maven), Eclipse Mars, latest version of Vaadin plugin, JRebel, tried Tomcat 7 and 8 (with runtimes servlet 3.0 and 3.1 respectively). The working environment that I recreated at home at first sight is the same… For the moment I don’t see how to reproduce this error at home.

The functionality of greying out a button is important, so I’ll investigate further, why I am unable to do this simple thing at work.

Found out where it was - in
Eclipse’s browser
a disabled button is invisible. The bug is present in both Luna and Mars.
In Chrome, Firefox and IE11 everything is fine.