Deployment to standalone Jetty gives directory listing but embedded jetty:r


Can run/debug app no problem using the jetty:run.

But when I create a war using “package -Pproduction” and drop into a standalone jetty webapps directory, the displayed page is a directory listing. I know that jetty can be configured to supress the directory listing, but it is a useful symptom that the .war file is not being served as an app.

@WebServlet(urlPatterns = "/*", name = "slot", asyncSupported = true,
    initParams = {
        @WebInitParam(name = Constants.I18N_PROVIDER, value = "com.adl.fdc.portal.TranslationProvider")
public class ApplicationServliet extends VaadinServlet
        implements SessionInitListener, SessionDestroyListener {

I’ve tried “/” and “/*” to no avail.
I’ve tried having the app as a named .war file and as ROOT.war
Interestingly it runs on tomcat.

Any pointers or assistance is greatly appreciated… I’m completely stumped.

Structure was initially created from vaadin starter (just plain - no spring, no CDI)
Using Intellij with embedded maven

pom.xml attached

17953395.xml (13.9 KB)