Deploying problems on OpenShift


I’ve created my first Vaadon project using the maven archetype:

mvn archetype:generate -DarchetypeGroupId=com.vaadin -DarchetypeArtifactId=vaadin-archetype-application -DarchetypeVersion=7.3.1 -DartifactId=VaadinHelloWorld -Dversion=1.0 -Dpackaging=war

And I’m able to launch it locally using “mvn jetty:run” and the page shows a button that I can click on.

But, I’ve tried several times to deploy it to a Tomcat 6 server on OpenShift and I keep getting a 404 error. The deployment reports successfully and there are no errors in the OpenShift log, so I’m leaning towards thinking it’s a Vaadin issue, but this is my first time using OpenShift, so I have no other projects to compare to.

To deploy, I cloned the OpenShift repository, deleted the src/ and pom.xml, copied the war generated from “mvn package” to the webapp folder and renamed it to hello3.war, and try going to {My OpenShift URL}/hello3 and I get a 404 message. I’ve also tried renaming it to ROOT.war and going to the root context, but also get a 404 error.

Have you found the solution regarding the deployment into OpenShift ??

Tomcat 6 does not support servlet 3 api; you should deploy your war in tomcat 7 or above