Dependency error when building Ant Script

I recently migrated from 6 to 7.3 but since I wasn’t able to install the 7 plugin via eclipse (network security) I created a dynamic Web Project and replaced the jars manually. All went well and my application is working great using the 7 libraries and add-ons

Now I want to create an ANT script for my newly migrated project, so I followed the instructions in the “Download” Page, configured my file and added it, with the others, to my project build path.

although when i run the build.xml as ANT build it gave me the following error

:: problems summary ::
problem while downloading module descriptor: invalid sha1: expected=

[ivy:resolve] misconfigured computed=b580ecd6328dcdec0363574c0eaa8827615f7777 (100ms) [ivy:resolve] module not found: com.vaadin#vaadin-server;7.3.0 [ivy:resolve] ==== local: tried [ivy:resolve] C:\Users\me\.ivy2\local\com.vaadin\vaadin-server\7.3.0\ivys\ivy.xml [ivy:resolve] -- artifact com.vaadin#vaadin-server;7.3.0!vaadin-server.jar: . . . [ivy:resolve] C:\Users\me\.ivy2\local\com.vaadin\vaadin-client-compiler\7.3.0\ivys\ivy.xml [ivy:resolve] -- artifact com.vaadin#vaadin-client-compiler;7.3.0!vaadin-client-compiler.jar: [ivy:resolve] C:\Users\me\.ivy2\local\com.vaadin\vaadin-client-compiler\7.3.0\jars\vaadin-client-compiler.jar [ivy:resolve] ==== shared: tried [ivy:resolve] C:\Users\me\.ivy2\shared\com.vaadin\vaadin-client-compiler\7.3.0\ivys\ivy.xml [ivy:resolve] -- artifact com.vaadin#vaadin-client-compiler;7.3.0!vaadin-client-compiler.jar: [ivy:resolve] C:\Users\me\.ivy2\shared\com.vaadin\vaadin-client-compiler\7.3.0\jars\vaadin-client-compiler.jar [ivy:resolve] ==== public: tried [ivy:resolve] [ivy:resolve] :::::::::::::::::::::::::::::::::::::::::::::: [ivy:resolve] :: UNRESOLVED DEPENDENCIES :: [ivy:resolve] :::::::::::::::::::::::::::::::::::::::::::::: [ivy:resolve] :: com.vaadin#vaadin-server;7.3.0: not found [ivy:resolve] :: com.vaadin#vaadin-themes;7.3.0: not found [ivy:resolve] :: com.vaadin#vaadin-client-compiled;7.3.0: not found [ivy:resolve] :: com.vaadin#vaadin-client;7.3.0: not found [ivy:resolve] :: com.vaadin#vaadin-client-compiler;7.3.0: not found [ivy:resolve] :::::::::::::::::::::::::::::::::::::::::::::: [ivy:resolve]



[/code]here is my ivy.xml

<?xml version="1.0"?>
<!DOCTYPE ivy-module [
    <!ENTITY vaadin.version "7.3.0">
<ivy-module version="2.0"
    <info organisation="com.example" module="v7proj" />
        <!-- The default configuration, which should be deployed to the server -->
        <conf name="default" />
        <!-- A configuration only needed when compiling the widget set. Should 
            not be deployed to the server -->
        <conf name="widgetset-compile" />
        <!-- The core server part of Vaadin -->
        <dependency org="com.vaadin" name="vaadin-server" rev="&vaadin.version;"
            conf="default->default" />

        <!-- Vaadin themes -->
        <dependency org="com.vaadin" name="vaadin-themes" rev="&vaadin.version;" />

        <!-- Precompiled DefaultWidgetSet -->
        <dependency org="com.vaadin" name="vaadin-client-compiled"
            rev="&vaadin.version;" />

        <!-- Vaadin client side, needed for widget set compilation -->
        <dependency org="com.vaadin" name="vaadin-client" rev="&vaadin.version;" />

        <!-- Compiler for custom widget sets. Should not be deployed -->
        <dependency org="com.vaadin" name="vaadin-client-compiler"
            rev="&vaadin.version;" conf="widgetset-compile->default" />

does anyone have an idea how I could resolve this?

Thanks in advance

My first guess would be that you have received a corrupted/truncated version of a JAR, causing the SHA1 verification to fail. Try cleaning your Ivy cache or at least Vaadin related directories in it.

I coudln’t find the option to clean all the cache when I right click on the ivy.xml so I went to the directory on my machine (user/me/.ivy2/cache) and deleted all the files in there. When I ran the build script again it gave me the same error

impossible to resolve dependencies:
    resolve failed - see output for details

and when I click on details it takes me to line 8 from the build.xml

    <ivy:resolve file="ivy.xml" />