Demo not working?

Just tried to click on some samples in the demo page, but can’t display.

All the demos and the sampler work fine on my end. No problem whatsoever. Did you try it with another browser? Or maybe you have a weird proxy between you and the internet which for some reason blocks the demos…?

what link?

Tried both Chome and IE. It said it’s communicaton problem.

Communication problem

Take note of any unsaved data, and click here or press ESC to continue.

(SyntaxError) : Unexpected token ) - Original JSON-text:[{“syncId”: 4, “changes” : [[“change”,{“pid”:“796”},[“0”,{“id”:“796”,“location”:“”,“v”:{“action”:“”}},[“actions”,{},[“action”,{“key”:“1”,“kc”:27,“mk”:
}]]]]], “state”:{“798”:{“internalChange”:1404294024590,“selectedPath”:“foundation”},“796”:{“pageState”:{“title”:“Foundation }> Vaadin Sampler”}},“960”:{“rpcInterfaces”:,“enabled”:true,“resources”:
,“callbackNames”:,“domainName”:“none”,“allowAnchor”:true,“universalTracking”:true,“trackerId”:“UA-658457-6”}}, “types”:{“802”:“13”,“798”:“10”,“796”:“0”,“960”:“15”}, “hierarchy”:{“802”:[“803”,“806”]

what’s the url?


I prefer to use these links:

These examples link to different applications then the one caris linked to. For example your link goes to the Vaadin 6 Sampler while Caris’ sampler link goes to the Vaaddin 7 version. They probably all have the same problem. That being something in your network. Vaadin is a Framework where Web applications and their contents may get quite big so they are quite more of a challenge for a slower/restricted bandwith then just a normal website. Communication problem indicates that you actually have a problem communicating to the Vaadin server. This might be caused by a slow bandwith, a proxy/firewall/whatever… slowing the communication from your computer to the internet or problems with your internet causing it to break temporarily.

I see similar problem on both chrome and firefox and it prevented me from browsing sampler application. I tried it on two different machines and got similar errors. Let me know if you need more details on it.


Same problem on my site.
I want to use this demo-page of Vaadin.

What I have tested before my reply?

  1. Updated Java to the newest version x64 & x86.
  2. Newest Firefox Version, Internet explorer and Google Chrome.
  3. Tried to use this software on my PC and on my notebook.
  4. 2 connections with Proxy-Server and 2 direct connections to the internet (ADSL)

Do I need any addon or something like that to use this page? Also get this communication problems or.
Please reply we need this page :o

Thanks in advance everybody

Little push …
I need your help guys :o

I can access the and it’s working.

Try to delete your cache, session and cookies in browser.
That’s the only suggestion I can give you. Also, just one tab only…


The is a cluster of two servers. One of them had 27g access log, on 30g hard drive. Combine that with vacation season and you can guess what happened :slight_smile:

The log file is now deleted so demos should be up and running again. Our server admin will have a top priority task when he arrives…


Thanks Matti…
Perfect everything is now working fine. Now I can work with Vaadin.
This will be awesome :slight_smile:

I’ve noticed that some demos does not work with Safari, just leaves a blank page. But then again there are many sites, not just vaadin demo that does that in Safari. I do like Safari as a user, but if developers choose to ignore Safari due to supporting it costs more that its worth I do understand. My Vaadin applications however seem to work with Safari, so I assume that there is something very special that triggers the blank page issue.

If you find demos that don’t work on Safari, could you report which demos (URLs) have problems and which Safari version you are using.

At least the official demos should work on Safari as it is a supported browser for the framework, so if they don’t, we have something to fix/update.

I am also facing the same problem ,vaadin demo is not working in safari browser .For below url ,themes are not applying when I tried to change the themes ,where changing themes is working fine in other browsers like chrome and mozilla ,check the below details

url ::!common
safari version :: 5.1.4 version

My Safari is in version 9.0.2 and I cannot see such an issue, any change you could update your Safari?


but why it is not working in safrai 5.1.4 ,it has to work in all the versions right.So please give me any solution to be work on this version .
Or any code changes to be done let me know

If think we officially support only the latest versions of Safari, but naturally if there is just some small thing to fix to support older ones, we should definitely do that. But I wouldn’t hold my breath on anybody here looking at this very actively. I’d guess it is just a fraction of a percent who is using that old Safari and the issue is apparently specific to only this demo.