Database libraries, JPAContainer problems...

First of all, let me say that I have been very successful using Vaadin over the past year or so, and I’d like to thank not only the developers, but everyone who has patiently answered the various questions I’ve asked. And here comes another one… This isn’t about Vaadin directly, but about the support structure around it. I’m not quite sure how to ask this, so appologies in advance for a bit of rambling…

My development/run time environment is quite simplistic - MySQL databases, Tomcat containers, an Apache front end web server. I usually access the databases using JPAContainers - and it all mostly works. The problems started recently when I tried upgrading to the most recent version of JPAContainer (2.0.x). Suddenly, nothing worked - missing routines from javax.Persistence, Filters that used to be part of the addon.JPAContainer now look like they need to be data.Container.Filter etc. Errors that seem to indicate that I have at
east one JPA v1.0 library where I need a JPA 2.0 library…

My problem is that I don’t think I really understand the database/library requirements well enough. I have thrown a set of libraries at my system that seems to work (until the new JPAContainer came along) but I don’t know if all of them are needed, or what I should replace them with.

I have the following Hibernate libraries in my build path:


Misc libraries (not sure if I need them all) like:

and all the other normal Tomcat libraries...

So I think my questions are:

  1. What exactly should I be using for the persistence libraries? I don’t require Hibernate particularly - I’m not configuring the Hibernate config files - just the persistence.xml - is there a simpler set of libraries I could be using? I use Eclipse → New classes from JPA tables to build my Java class files…

  2. What do I need to add/replace so that the new JPAContainer will work?

  3. I’m not sure if there are other questions I should be asking here - suggestions, pointers to documentation or examples welcome…

Thanks very much


I spent quite a bit of time over the weekend, and I eventually figured out how to get rid of the random Hibernate libraries I was using and replace them with the latest versions of EclipseLink. This seems to have had the effect of bringing my system up to date - I can now use the most recent version of the JPAContainer successfully. This also seems to have fixed another problem I was asking about - the StaleStateException I was getting in the JPAContainer seems to have gone away…