Custom component can not find implementation

I have tried making the charts from the

I made a new vaadin project in eclipse, put together all the java files as well aas the widgetset.gwt.xml file as they can be found from the incubator.
I had to change some import package names as the gwt-graphics packages have changed.
I then compiled the project without problem and compile the widgetset without problem either.

But when I try to open the demo application I get :
Widgetset does not contain implementation for com.example.charts.BarChart. Check its @ClientWidget mapping, widgetsets GWT module description file and re-compile your widgetset. In case you have downloaded a vaadin add-on package, you might want to refer to add-on instructions.
And then the raw UIDL.

I checked the @ClientWidget which is in the form : @ClientWidget(VBarChart.class)
I thought maybe the widgetset compiler didn’t compile those files, so I changed the VBarChart so that it would not compile and the widgetset build failed.

I tried changing my tomcat classpath and also making a jar out of the project and importing it without any success.

I think I am missing something really simple.

Somebody has an idea where to look at ?

I looked at the source of several add-ons and have seen that the @ClientWidget was using the full class name.
I tried to change mine but vaadin is still not rendring the components.
I also tried adding the client side classes in my tomcat classpath and to make a .jar file out of them but it never finds the client side classes.

I am out of ideas for the moment. Anybody ?

Do you have your client side classes under the client package? The GWT compiler only finds the classes under that package.

Have you turned on verbose debugging messages and does your components get listed in the output?

Thank you for answering,

I have tried putting the client side components under client and client.ui (as I have seen it in some add-ons from the directory) without success.

In the verbose log, the components are listed and no error or warning are showing.
I have put the log on pastebin in case more trained eyes can pick up a problem :

I made a new project, copy/pasted everything inside and… it’s working now.
I can not find any difference between my previous project and this one but maybe some settings somewhere.