Critical: Empty web page building on a Mac

I had a full working environment until a few days ago. Yesterday when building on a Mac OS the client code shows an empty page. Inspection shows the main Div is empty. Tried a different workspace, same problem. Tried a different Mac: same problem.
Of course cleaned browser caches all along.

My co-workers on Linux and Windows do not have this problem.

I am not sure if something has changed on a recent Mac OS upgrade (High SIerra 10.13.1), or any other readon.
I am stuck.
I even tryed switching to a different version of Java 8 compiler.

I build with gradle 4.2.1, and Vaadin Gradle Plugin com.devsoap.plugin.vaadin 1.2.4

The empty div shows:

Building on a small app, with Maven, worked OK.

I’ll appreciate any suggestions.



That is the top app Div on working environments, for example:
[font=Courier New]

<div class="v-csslayout v-layout v-widget nav-panel v-csslayout-nav-panel v-.. [/font]

Thanks John, forgot about the inspector, however once I enabled it it shows absolutely nothing.
On the other hand I looked at the Chrome console and found this:

vaadinBootstrap.js?v=8.1.6:34 GET https://localhost:8443/Pv3/VAADIN/themes/pv3/styles.css?v=8.1.6 net::ERR_CONTENT_DECODING_FAILED
loadTheme @ vaadinBootstrap.js?v=8.1.6:34
bootstrapApp @ vaadinBootstrap.js?v=8.1.6:221
initApplication @ vaadinBootstrap.js?v=8.1.6:247
(anonymous) @ ?debug:26

Hi Reuben,

It sounds like you are getting a Javascript error when the page is loading, did you resently add any new Javascript functions or such that could have broken the app? You can check this by keeping the Development Inspector open when loading the page.

Of course it could be some old artifacts still lingering in the gradle cache as well. You could try running
gradle clean
, ensure that you don’t have any files under VAADIN/widgetsets remaining and then rebuild the project.


Looks like your css file is corrupt. You can safely remove it and run
gradle vaadinThemeCompile
to re-create it.

Hi again.
I have in all the above trials fully rebuilt everything. Furthermore I see the correct css content loaded to the browser, but not the correct HTML code.