Composite design Editor XPCOM error under linux 64bits

Hello dears,

Hope you doing fine.

So I’ve been struggling for a while now with this exception on using the design editor under gentoo 64bits edition, I’ve tried following a lot of bug report solution regarding other swt based framework issue, and/or eclipse, nothing seems to work and can’t really find anything useful on vaadin related topics.

Here is my environment set-up:

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -data /home/cthu/workspaces -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.jee.product

Initial error is, after installing the Vaadin eclipse plugin, trying to edit a composite with the visual designer will close the workspace with

!ENTRY org.eclipse.ui.browser 2 0 2012-03-29 15:04:03.338
!MESSAGE Internal browser is not available: No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]

I’ve tried setting the env var to several version of Xulrunner/mozilla/firefox, without any success, every downloaded package is 64bit version, depending on the mapping, I constantly receive various version of XPCOM error

#1: !ENTRY org.eclipse.ui 4 0 2012-03-29 15:27:56.131 !MESSAGE Unhandled event loop exception !STACK 0 org.eclipse.swt.SWTError: XPCOM error -1041039104

#2 !ENTRY org.eclipse.ui 4 0 2012-03-30 08:58:43.341 !MESSAGE Unhandled event loop exception !STACK 0 org.eclipse.swt.SWTError: XPCOM error -2147467261

what I also tried without any success is to set-up the vm argmuent in eclipse.ini:


Thanks for you help!