ComboBox inside popupbutton problem

Hi,

I’m having a problem with a combobox inside a popupbutton, it isn’t rendering correctly (see attached image). By the way, the browser is firefox, safari is rendering different, but still wrong.

I don’t know if it is because i’m using a popupbutton or i’m doing something wrong. I use other combobox in a window and it is rendering correctly.

Thanks.
11552.png

This is most likely a theme issue. The popup element of the PopupButton doesn’t contain necessary CSS class names in order for the ComboBox to draw correctly.

Hi,

I fixed the issue so that now the popup has the “v-popupview-popup” classname too. Version 1.1.0 can be found from
Directory
.

-Henri

Thanks both of you.

Henri, the version 1.1.0 hasn’t solved my problem, any idea how can i fix it? By the way, great addon.

Thanks again :smiley:

Did you recompile your widgetset? I added a ComboBox example to the
demo
application, and after the fix it looks correct.

Sorry Henri, my fault, i forgot that i had disabled the feature in eclipse to automatically recompile the widgetset :*)

Thanks a lot, now it works perfectly.