Columnwidths of table-header and table-body don't match

Hi,

with vaadin 7.1.14 I wrote a simple testprogram:

import com.vaadin.server.VaadinRequest;
import com.vaadin.ui.Table;
import com.vaadin.ui.UI;
import com.vaadin.ui.VerticalLayout;

@SuppressWarnings(“serial”)
public class LongTableRowUI extends UI {
private static final int NUMBER_OF_COLUMNS = 50;
private static final int NUMBER_OF_ROWS = 10;

@Override
public void init(VaadinRequest request) {
    VerticalLayout layout = new VerticalLayout();
    layout.setSizeFull();
    setContent(layout);

    Table table = new Table();
    for (int col = 0; col < NUMBER_OF_COLUMNS; col++) {
        table.addContainerProperty(col, String.class, null);
    }
    for (int row = 0; row < NUMBER_OF_ROWS; row++) {
        String item = new String[NUMBER_OF_COLUMNS]

;
for (int col = 0; col < NUMBER_OF_COLUMNS; col++) {
item[col]
= row + “/” + col;
}
table.addItem(item, row);
}
layout.addComponent(table);
}
}

When I look at the generated output (with firefox or ie doesn’t matter), the widths of the columns in the header are not equal to the width of the corresponding columns in the body (see attached jpg).

I don’t know, what’s wrong with the program. Could anybody please help me?

13561.java (917 Bytes)

I just added the missing jpg.
13562.jpg

which browser are you using? just tried Chrome, FF and Safari, all working fine
13563.png

I tried it with firefox and ie.
I’m not sure, but when I first started my app, all worked fine. Then I changed it just a little bit (increased the number of columns), deployed it again, and I the effect I described above appeared and never vanished.

spotted a small problem, String item = new String[NUMBER_OF_COLUMNS]
; should be String item = new String[NUMBER_OF_COLUMNS]
; But I think it’s only a typo. Otherwise, the code is good.

But sorry, I still cannot reproduce the your problem, even increase/decrease column numbers.

Is this exactly the code you are using for testing?

btw, did you use the ?debug parameter to see if anything wrong in rendering the content?

I deinstalled firefox and installed it again … and now everything is working fine.
So the problem has nothing to do with vaadin or my program. But with some caching (or so) in the browser.
Whereas firefox is now working, I still have the same problem with ie. Even a reset of all ie-settings (incl. caches, cookies and so on) did not fix the problem.
Any idea?

Don’t know which version of IE you are using, if it’s a bit old, maybe you upgrade to a newer version?

I have forgotten to restart ie after resetting. Now everything is ok.
Thank you for your help.
Although at the moment everything is working, the situation is still a little bit unsatisfactoy, because we don’t know the reason of this problem. I hope, it will never reoccur.