CKEditor jumping cursor

Hello Forum,
I’ve been using the [latest]
ckeditor (7.10.6) with Vaadin 7.6.1, and I’ve run into a problem that I just can’t get to the bottom of.

Whenever the editor is in wysiwyg mode, it randomly decides the cursor should go back to the start of the editor (0,0).
It’s intermittent, and doesn’t correspond to page changes/immediate etc. (not that there are any).
Oddly, it
happens when typing…if I type some stuff, then leave the cursor there, it’s fine. Start typing again, and at some point (typically within 5secs) it will reset the cursor again to the start. As you can imagine, it’s not the ideal scenario for a text editor.
When in Source mode, it never does this.
I read somehwere that wysiwyg mode has listeners that get fired, and they don’t get fired when in source mode.
Has anyone else seen this problem? Is there a way 'round it?
FYI, I’ve tried disabling plugins until I got to where there is no editing at all; changed toolbar settings; many many config combintations - nothing fixes this, except removing all plugins (no editing or viewing at all) or leave in source mode. Neither is really an option.

Any insight into this issue is much appreciated!


Give the new 7.10.7 release a try. It has a patch from Matti that resolves this, which appears to be related to systems that use long polling.

Hi David,
Thanks for your quick reply. Downloaded 7.10.7. Compiled it. Ran it. Fixed it.
It’s times like this I’m so glad to be in and around the Vaadin professionals.
Really great work, and many thanks to you and Matti for the Add-on and maintenance!