Can't use charts with commons-io 2.5

I’m unable to recompile (Maven) a project vaadin charts . The project now depends on apache commons-io 2.5 and Vaadin charts uses 1.4. Tried to exclude org.apache.commons:commons-io from charts dependency but then Maven looks vor commons-io 2.5 in Vaadin repository. Any suggestion?

Hi Franco,

Do you have a direct dependency to commons-io 2.5? In that case priority should be given to 2.5 version, and it shouldn’t use vaadin repo for it.

Can you check if the resolved version is correct by using the following:

mvn dependency:tree -Dverbose -Dincludes=commons-io At least in a test project I get

[INFO] [INFO] +- com.vaadin.addon:vaadin-charts:jar:3.0.0:compile [INFO] | \- (commons-io:commons-io:jar:1.4:compile - omitted for conflict with 2.5) [INFO] \- commons-io:commons-io:jar:2.5:compile And when building it tried vaadin repo, but succeeded only with maven central repository

Downloading: Downloading: Downloaded: (13 KB at 21.3 KB/sec) Hope this helps,


Hi Guille,

Thank you very much indeed for your fast suggestion, that’s was infact one of my trials, the problem is - when I move up org.apache.commons:commons-io:2.5 I get the error:

Failed to execute goal on project ps.discuss: Could not resolve dependencies for project net.cbsolution:ps.discuss:war:1.0-SNAPSHOT: Could not find artifact org.apache.commons:commons-io:jar:2.5 i

n vaadin-addons (

Really a strange error: why Maven does not pick commons-io from Maven Central (inherited Super POM) if it does not exist in Vaadin repository? I would espect that from Maven, but it does not: for some reason Maven
insists in getting commons-io from Vaadin repository

Oh, now I see the issue, latest versions are under commons-io group id in maven.

Not sure if it was an issue with a single version, or what was the internal but at least
shows the artifact as moved, and there’s some more info around:

If in doubt check the pom.xml in apache’s mirror in github:

Try changing the dependency definition to:

<dependency> <groupId>commons-io</groupId> <artifactId>commons-io</artifactId> <version>2.5</version> <dependency> That should make the trick


Thank you very much Guille, I would have never noticed the change of Group-ID (Time has come to start using eyeglasses :slight_smile:

You made my day (actually 2 days).


It was a sneaky change, indeed.

Glad it helped!