Can't open the Simple App

Hello! I’m new to Vaadin and I want to re-do a previous native app I had for desktop, however I want to check the Simple App code to learn more about that but I can’t get it to work.

I’m running Eclipse IDE for Java EE 2019.12 and I did the maven install, config the build with jetty:run but just at starting the app it says:

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.

When I open the page localhost:8080 the page looks weird and it shows an error on the top right with this:

Webpack Error
Webpack build failed with errors:
ERROR in ../target/frontend/generated-flow-imports.js
ERROR in ../target/frontend/generated-flow-imports.js

I started another small app with the spring boot and it started perfectly. However I want to start this one so I can get a better idea on how the app works.

Thanks in advance!


I get the same error (see attached).
And file generated-flow-imports.js is not included in this application.


I had a similar error multiple times while trying to upgrade to V14 NPM and also while trying to start the bakery app or simple spring-boot starter. The following worked for me:

delete node_modules
delete package-lock.json
delete target
mvn clean install
npm install

Worked for me too, thanks Martin.