Can't get the Router Online Training Example to work

hyvä päivä,

i am new to Vaadin and started to look through the online Tutorials and Trainings this week.

I wanted to start with the [Vaadin 10: Router API]
( curse and downloaded the maven-projects from that site. I imported them in Eclipse like it is described in the Video.

But when i run them, i can’t visit any Page (tried localhost:8080, localhost:8080/home). I just get the 404-Page of the Tomcatserver. I tried it with Wildfly14 as well. I tried the “Excercieses”-Project with a manually added @Route(“”) annotation and i tried the “Solutions/solution-step1”-Project as it is. They run on a Tomcat9 inside Eclipse. I built them via right mouseclick → run as → maven install. I get no Exceptions, eclipse uses JDK 8, my browser is chrome.

I hope someone can help me. I’m feeling really dumb because of this nooby problem.

Greetings from Cologne, Germany
Dennis Bundszus

Hi Dennis, thank you for trying out the online course. I think the problem is the context path of tomcat server. By default, with Eclipse + Tomcat, the context path is the project name, which is solution-routing-step1, which means that you can go to http://localhost:8080/solution-routing-step1/ you will be able to see the application (For the solution step 1).

The context root could also be checked and modified by Right-click the project → Properties. In the popup window, select “web project setting”, as shown in the attached screenshots

Thank you again for the question, I believe this could be a very common problem for Eclipse + Tomcat users. Hope others with similar problems could find this thread.