Can't create Eclipse/Vaadin 8/Maven project (pom.xml errors)

Just downloaded the Vaadin 8 jar files and tried to create a simple web project in Eclipse. The project gets created but the pom.xml file has errors. Specifically:

"Could not get the value for parameter webappDirectory for plugin execution default (com.vaadin: vaadin-maven-plugin: 8.0.5: compile: default: process-classes)

I found something on the web that suggested deleting the /home/nbc/.m2/repository directory, cleaning the project and updating it, but that did not work. I have not used Maven before, at least not explicitly like Vaadin 8 seems to be doing. What do I need to do to get a project up and running?

Pom.xml file is attached


32104.xml (4.88 KB)


As a first test I created an empty folder, downloaded your pom.xml file there and ran “mvn clean package”. This resulted to no errors in the maven compilation. Which version of Eclipse and Vaadin Eclipse-plugin are you running?

I am running Eclipse::Mars, and I downloaded Vaadin 8.0.5. I tried again building a Vaadin 7 project (after removing the .m2/repository directory) and that seemed to create a valid project


@Neil Re:

Purging your local Maven repository (located in
by default which can be overridden in
) is usually just one of the last resorts. It may help but it potentially increases the runtime of your next build(s) significantly (if you have many or large projects) since all the dependencies, including transitive ones, have to be downloaded from
Maven Central
(or wherever they reside) again. And hopefully you haven’t installed some with


manually. And hopefully you’re not relying on own project’s dependencies that were
mvn install

on your machine only since then all these projects might have to be built again (if Eclipse M2E’s workspace dependency resolution doesn’t work or can’t work because they were created in a different workspace).

A less drastic approach, if at all, is to delete just the directories of artifacts that cause issues from your local repository.