Cannot checkout sourcecode from SVN?


I just tried to checkout the sourcecode of both version 6.7 and 6.8 without success. First I tried it with Eclipse, using SVN Connector “SVNKit 1.3.5 r7406 (SVN 1.6.15 compatible, all platforms”, which gave the error message

Then I tried it from commandline, using “svn, Version 1.6.12 (r955767)”, resulting in the following error message

In English that means something like “Unexpected end of Svndiff input data”.

Does anybody have an idea what the problem might be here?

Thanks for any hints,

Just tried with command line SVN 1.7.2, no problems encountered.

I would first check whether there might be some firewall or proxy between you and that could cause problems for large SVN checkouts.

I just checked and there is no proxy configured. My guess is that SVN 1.7 client is required, but Ubuntu is still at 1.6. I’ll give it a try when this gets more urgent for me (don’t want to run into trouble with my company’s 1.6 server right now…)

Subversion 1.7 release notes

Therefore, this should not be the issue, but probably still worth testing.

I just tried again with Eclipse 4 Juno M5 and the SVN connector “SVNKit 1.3.6-v1 r7998 (SVN 1.6.17 compatible, all platforms)”, and now I was able to do the checkout.